CodeIgniter Forums
Just installed CI4 RC1 but getting blank pages - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: CodeIgniter 4 (https://forum.codeigniter.com/forum-28.html)
+--- Forum: CodeIgniter 4 Support (https://forum.codeigniter.com/forum-30.html)
+--- Thread: Just installed CI4 RC1 but getting blank pages (/thread-74253.html)

Pages: 1 2


Just installed CI4 RC1 but getting blank pages - mymisty - 09-03-2019

Hi,

I have just installed RC1 to play with it, however I am just getting blank pages for the default home controller and any other controllers I create. It doesnt seem to be loading to views?

The logs dont show anything except that the controller has been loaded.

Any ideas?


RE: Just installed CI4 RC1 but getting blank pages - InsiteFX - 09-03-2019

Did you set your base_url in .app/Config/App.php ?


RE: Just installed CI4 RC1 but getting blank pages - mymisty - 09-03-2019

yep the base_url is set


RE: Just installed CI4 RC1 but getting blank pages - ciadmin - 09-03-2019

@mymisty WHich installation method did you use?


RE: Just installed CI4 RC1 but getting blank pages - mymisty - 09-03-2019

manual


RE: Just installed CI4 RC1 but getting blank pages - ciadmin - 09-03-2019

Are you running it with Apache? or "php spark serve"?
Which URL are you using in your browser?


RE: Just installed CI4 RC1 but getting blank pages - mymisty - 09-03-2019

apache. domain.com outputs blank page, domain.com/controller/method outputs blank page.

figured its something to do with output_compression is php, if set to On, i get headers already sent errors and blank pages. if set to Off, all works fine. 

OR

if i remove 

Code:
while (\ob_get_level() > 0)
    {
        \ob_end_flush();
    }

    \ob_start(function ($buffer) {
        return $buffer;
    });

 from /app/Config/Events.php and keep output_compression on, it works.


I have submitted a bug here: https://github.com/codeigniter4/CodeIgniter4/issues/2182


RE: Just installed CI4 RC1 but getting blank pages - ciadmin - 09-03-2019

I would leave output compression off until the issue you raised is resolved Smile


RE: Just installed CI4 RC1 but getting blank pages - InsiteFX - 09-03-2019

I just installed and it works fine here.


RE: Just installed CI4 RC1 but getting blank pages - mymisty - 09-03-2019

With php compression set to on?