• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeExtinguisher 2.0 Release Candidate 14.2

#61
[eluser]Bruce Brown[/eluser]
Jtaby,

Here's how I've gotten Code Extinguisher to work when having the app outside the root of the site.

1. I’ve moved the entire codex app folder to my general, multi-site CI applications directory, which is /ci/apps --outside of the public root of my site -- so, in my case, the relative url from my site root to my CI apps directory is “../ci/apps/”. (When I say entire codex folder, I mean I placed the codex folder which itself includes the "application" folder and the "assets" folder in my /ci/apps folder.)
2. I've placed backend.php in the public root of my site, and then I’ve renamed the “backend.php” to “form.php” (because I'll use it to create public forms for the site and I want a meaningful url).
3. I’ve changed the apps index page setting from "backend.php" to “form.php” in /codex/application/config/config.php.
4. I copied the assets folder from the codex directory into the root of my site. I named it "ce_assets".
5. In /codex/application/config/codex.php, I’ve modified the following line of that file as follows:
Code:
$config['codex_asset_folder']= $config['base_url'].'ce_assets/';

You've told me that having multiple assets folders is unwise, as it interferes with updating the application. So, I've deleted the content in the default assets folder, under the the codex directory. I placed a text file in that folder telling to where the assets folder content has been moved.

Everything works fine!

Thanks very much for the help! Smile

Bruce

#62
[eluser]Majd Taby[/eluser]
good idea, glad you got it working Smile

#63
[eluser]abmcr[/eluser]
Hello... i apologize for my continuous requests/suggestions; if hope not to be too exaggerated :roll:
I have a strange error when in the example_form.yml of the last build, i insert the OneToMany field into the Filed set. My code is
Code:
image_test:
    class: Image
    params:
        make_thumbnail: true
        height:100
        width:100
        url_path: uploads/
        upload_path: ./uploads/
general_information:
    class: FieldSet
    params:
        form:
            related_example:
                class: OneToMany
                params:
                    display_field: name
            textbox_test:
                class: TextBox
......
At this moment, all work fine (a little bug with the alignment is fix with an edit as line 245 of plugins/relationalcontainer.php; the correct line is
Code:
</div><div style="clear:both">&nbsp;</div>
), but if go back into the display view i get an error SQL
Code:
An Error Was Encountered
Error Number: 1054

Unknown column 'related_example' in 'field list'

SELECT `image_test`, `related_example`, `textbox_test`, `checkbox_test`, `date_test`, `password_test`, `radiogroup_test`, `sessiondata_test`, `textarea_test`, `time_test`, `dbdropdown_test`, `file_test`, `my_id` FROM (`example`) ORDER BY `my_id` desc
And in effect, the field related_example is not present into the table. But why this error only if i move the position of the field?
The codexforms/iterate function work wrong only for the position of the yml code?

Another little tip: i want to get the id of the record int the prepForDisplay routine of a controller... it is possible?

Thank you

#64
[eluser]Majd Taby[/eluser]
abmcr, I love your involvement with the project. But to answer your questions:

1) You might have found a bug, i'll fix it asap

2) check out the $this->codexadmin->active_id attribute Smile

#65
[eluser]abmcr[/eluser]
[quote author="jTaby" date="1211916743"]abmcr, I love your involvement with the project. [/quote]

Thank you :-)

#66
[eluser]Majd Taby[/eluser]
Hey guys, i'm just posting this link to get some input. It's the static-html version of the codex website.

Main page: http://71.65.20.84:81/codexsite/
Previous Releases: http://71.65.20.84:81/codexsite/previous_releases.html
All Plugins: http://71.65.20.84:81/codexsite/plugins.html
Single Plugin: http://71.65.20.84:81/codexsite/lorem_plugin.html

#67
[eluser]got 2 doodle[/eluser]
nice layout

Do you like the color blue by chance? :-)

#68
[eluser]ocergyNohtna[/eluser]
quick question. i've gone through many iterations of CE by now and i have a few different "branches" i'm working with. is there anywhere in CE that i can look to find what version and RC are?

#69
[eluser]Majd Taby[/eluser]
um, yeah you're right, i need to define a constant somewhere. But the only way I could think of is by trying to match one of the files (I'd go by the ManyToMany plugin, that sees updates "almost" every release) against http://codeextinguisher.com/trac/codex

#70
[eluser]ocergyNohtna[/eluser]
hahahah, nice. Smile and isn't it ironic that that's the plugin i'm having the most issues with, that spawned the question initially. so let me take this another direction. i believe i'm using RC10 with this project since the many to many extends codexForms. i've noticed the latest versions of CE have manytomany extending a relationalForm (or something similar...) my question is if i wanted to scrap the rc10 version of manytomany and use the latest, would i need anything else other than the new manytomany and the new relational? or would a lot more work be needed, in which case it may would be easier to update my entire project first...any thoughts?


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.