• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Session doesn't work after update from 2.2.1 to 3

#1
Hello, before few days I update my CI using this tutorial and now even though that I've choose driver to be "files", CI tries to save my session in the db.
I have encryption key in the config and this is my session config
PHP Code:
$config['sess_driver'] = 'files';
$config['sess_cookie_name'] = 'ci_session';
$config['sess_expiration'] = 7200;
$config['sess_save_path'] = NULL;
$config['sess_match_ip'] = FALSE;
$config['sess_time_to_update'] = 300
This is my code
PHP Code:
$session = array(
                
'email' => $user,
                
'user_id' => $id                
            
);
            
$this->session->set_userdata($session); 

and this is the result http://grab.by/F0mk

I tried to use $_SESSION, but it gives me the same error.

On another project I put fresh 3.0 version and I used the same code for new session and everything is okay... Any ideas what to do?
Reply

#2
I see that you have not specified the actual sess_save_path in $config.

I do not find any information about the default action of the 'files' driver if that path is NULL. There is a note that the final fall-back option attempts to use settings in your php.ini for session settings.

Try setting that absolute path and making sure that the directory has correct access permissions.
Reply

#3
Try setting your $config['sess_save_path'] to an actual directory. From the config file: "For the 'files' driver, it's a path to a writable directory... IMPORTANT: You are REQUIRED to set a valid save path!". I'd suggest a directory outside of your public folder that is not publicly readable (/YOURUSER/tmp or somewhere similar).
Reply

#4
You seem to be overriding the library with your own application/libraries/Session.php.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.