• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
flexi auth - A user authentication library for CodeIgniter

[eluser]MrTomTom[/eluser]
Hi There,

I am trying to upgrade a system to CI3 however I cannot get FlexiAuth to work with it. When I try and load Flexi_auth I get the following error

Quote:Severity: Error
Message: Class 'CI_Flexi_auth_lite' not found
Filename: core/Common.php
Line Number: 185

I presume this is because it can't find Flexi_auth_lite in the libraries folder so it goes on to look for it in the system libraries? Does anyone have any idea how to fix this?

[eluser]fabioferrero[/eluser]
I've a developer installation with CI 2.2.0 and last flexi auth that worked well on OsX Mountain Lion. Few days ago I've upgraded the operating system to OsX Mavericks, and flexi auth start to doesn't work well. I've many sql error like:

Code:
Error Number: 1064

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'user_accounts`.`uacc_id`' at line 7

Filename: models/flexi_auth_lite_model.php

Line Number: 213

What's wrong?

[eluser]fabioferrero[/eluser]
[quote author="fabioferrero" date="1412756018"]I've a developer installation with CI 2.2.0 and last flexi auth that worked well on OsX Mountain Lion. Few days ago I've upgraded the operating system to OsX Mavericks, and flexi auth start to doesn't work well. I've many sql error like:
What's wrong?[/quote]

Seems that all works well, the only problem is the error_reporting (and warning/notice) that are changed from php 5.3.15 (in Mountain Lion) to php 5.4.17 (in Mavericks). Added

Code:
error_reporting(0);
and apparently all works again...


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
2 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.