Poll: Which PHP version features should CI 4 target?
You do not have permission to vote in this poll.
5.4
23.26%
20 23.26%
5.5
12.79%
11 12.79%
5.6
50.00%
43 50.00%
5.3 (unsuported already)
1.16%
1 1.16%
This should depend on dev process
12.79%
11 12.79%
Total 86 vote(s) 100%
* You voted for this item. [Show Results]

  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which PHP 5.X version should be considered as Required

#21
It's great to see life being breathed back into CI again and plans are being made for future versions.

What would be useful in this debate is some kind of a high level strategy/roadmap for CI4 and an approx target release date. The time taken to release this will obviously depend on the features/updates to the code base. However saying it'll be ready when it's ready brings back really bad Ellis Labs memories. Is there at least some target date in mind? Based on this date it'll be easier to see how this fits into PHP version support.
Reply

#22
I read most of the comments and lol'd.

It's going to be 5.2. Just look at Cake 3.x. It requires PHP 5.4.16 or greater. People who have commented here would freak out!

I have said time and time again. Let CI 3.0, be for the devs who just will not upgrade. For whatever reason, leave them behind. With CI 3.0, just do security fixes.

With CI 4.0. Insist on PHP 5.4+. Whatever version.

For me personally, I couldnt care less. I've already stepped out of this discussion. I've been using HHVM since August last year. Been running nicely.

My response is, PHP what?
Reply

#23
I think, that the question in this vote is wrong and the proposed list of options is incomplete. I am proposing this particular vote to be closed and a new vote that allows PHP7 as a choice to be done.
Reply

#24
(04-10-2015, 11:28 AM)ivantcholakov Wrote: I think, that the question in this vote is wrong and the proposed list of options is incomplete. I am proposing this particular vote to be closed and a new vote that allows PHP7 as a choice to be done.
PHP7 is not an option..
It will need atleast 1-2 years and even php7.1 to be out before we can focus it..
Best VPS Hosting : Digital Ocean
Reply

#25
We are taking it from the bad end. I think, the PHP 5.4 is a real considered minimum. Do PHP 5.5 or 5.6 have any desirable super trooper or even standard funcionality which can not or should not be omited? PHP 5.3 have namespaces. PHP 5.4 have short opening tags. PHP 5.5 have password_hash function... I think you get my point.
Reply

#26
(04-11-2015, 12:00 AM)sv3tli0 Wrote: PHP7 is not an option..
It will need atleast 1-2 years and even php7.1 to be out before we can focus it..

Such long timescales. People are coding in php 5.6+ and hack. Will probably blow your mind too but are also developing frameworks in 5.6+ and hack.

If you are projecting 2 years after Dec, thats Dec 2017 codeigniter 4 will be out.

Some of us can't and won't wait that long. Big Grin
Reply

#27
(04-11-2015, 07:07 AM)no1youknowz Wrote:
(04-11-2015, 12:00 AM)sv3tli0 Wrote: PHP7 is not an option..
It will need atleast 1-2 years and even php7.1 to be out before we can focus it..

Such long timescales.  People are coding in php 5.6+ and hack. Will probably blow your mind too but are also developing frameworks in 5.6+ and hack.

If you are projecting 2 years after Dec, thats Dec 2017 codeigniter 4 will be out.  

Some of us can't and won't wait that long.   Big Grin
Go to laravel for those who can't wait.
Reply

#28
No offense to anybody, we need a question without an opinion implanted within it. I see here valuable comments and arguments, but the voting is compromised.
Reply

#29
(04-11-2015, 10:41 AM)nfaiz Wrote: Go to laravel for those who can't wait.

Actually for some things laravel is very slow. But then again, it's definitely out of bounds of this forum. Big Grin
Reply

#30
Whilst I'd love to see Codeigniter working with the latest PHP version ( I'm currently running it on both dev and production using PHP 5.6) we have to be realist about the hosting availability. A lot of sites are going to be hosted on shared web hosting, which in most cases means Centos/cPanels.

So perhaps rather than setting our PHP version why don't we just peg it with cPanels with backward compatibility -1. Codeigniter has always been good with backward compatibility and I would hate to see us lose that.
Most things broken in our house was done by nobody, the rest was my fault anyway Huh
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.