• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter Simple and Secure Twig

#31
@mstdmstd
You can use config file for the library. That is `application/config/twig.php`.
You can see sample: https://github.com/kenjis/codeigniter-ss-twig/pull/8
Reply

#32
I've just released v0.3.0: https://github.com/kenjis/codeigniter-ss-twig/releases
Reply

#33
Update your Twig!

Twig: Sandbox Information Disclosure
Twig 1.0.0 to 1.37.1 and 2.0.0 to 2.6.2 are affected by this security issue.
The issue has been fixed in Twig 1.38.0 and 2.7.0.
https://symfony.com/blog/twig-sandbox-in...disclosure
Reply

#34
Hi there!

I've started to develop codeigniter-ss-twig for CodeIgniter 4!
See https://github.com/kenjis/codeigniter-ss-twig/tree/4.x

[edited]
This post may be wrong place. So I created a topic on CodeIgniter 4 Addins:
https://forum.codeigniter.com/thread-78185.html
Reply

#35
I have released codeigniter-ss-twig v4.0.0 for CI4.
So if you install codeigniter-ss-twig for CI3 via Composer,
set the version number:
Code:
$ cd /path/to/codeigniter/
$ composer require kenjis/codeigniter-ss-twig:^1.0
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.