• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
404-page-not-found-the-page-you-requested-was-not-found

#1
Hello,
 
 
Please I need your help on my codeigniter project.
 
 

I have a codeigniter project which works fine on my local machine, but when I uploaded it to a hosted Domain server, I start getting this error message “404-page-not-found-the-page-you-requested-was-not-found” I have tried my possible best but still can't get a positive result. 

I run codeigniter Version 2.2.2. and below are my file configuration:

Below is my config.php file showing the base url of my application:
$config['base_url'] = 'http://www.nicebis.com/';

This section contains the .htaccess File:
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
Options -Indexes


This section shows my database.php file:
$active_group = 'default';
$active_record = TRUE;
$db[
'default']['hostname'] = 'localhost';
$db[
'default']['username'] = 'username';
$db[
'default']['password'] = 'password';
$db[
'default']['database'] = 'databasename';
$db[
'default']['dbdriver'] = 'mysql';
$db[
'default']['dbprefix'] = '';
$db[
'default']['pconnect'] = TRUE;
$db[
'default']['db_debug'] = TRUE;
$db[
'default']['cache_on'] = FALSE;
$db[
'default']['cachedir'] = '';
$db[
'default']['char_set'] = 'utf8';
$db[
'default']['dbcollat'] = 'utf8_general_ci';
$db[
'default']['swap_pre'] = '';
$db[
'default']['autoinit'] = TRUE;
$db[
'default']['stricton'] = FALSE;


My rout.php file is below:
$route['default_controller'] = "account/login";
$route['404_override'] = '';


Please what is it that i'm not getting right? I will also appreciate if you can remotely login to help resolve it. I'm available via TeamViewer or any other online means you will recommend. 

I have been on this for a while now, please help me.


Thanks in anticipation
Ebere
Reply

#2
Try this:

Code:
Options -Indexes
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [QSA,L]

Some times you need to add the ? mark after index.php

Also you may need to set the RewriteBase to your server.
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#3
@InsiteFX  I have tried the using this as you stated yet, its still showing " 404 Page Not Found The page you requested was no found." . Also i have RewriteBase enable on the server. The Application is hosted with a hosting company. Please if you wouldn't mind can you login to my system so that you can help me look at it. We can use TeamViewer.  I have been on this for a while now 
Reply

#4
It may be because you have a sub-folder in the default route, I think they made a patched router file to work with routes like that.

By rights the default route should not be in a sub-folder.
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.