• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
index.php on https not working .htaccess

#1
Guys, i have problems with my configuration because i cant eliminate the "index.php" after i pass the site to https.

for the https i have used letsencrypt and use one hook to ssl.php that give the page obligation to stay on https, but now its not working my configuration on the .htaccess file.

Help pls 
Huh
htacces=
Code:
RewriteEngine on
RewriteCond $1 !^(index\.php|resources|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]

config.php
Code:
$config['index_page'] = '';
$config['url_suffix'] = '';
Reply

#2
let your index.php in your $config.. its working for me using https
God Bless CI Contributors Smile
Reply

#3
Hello,

Change in config.php file:

$config['uri_protocol'] = 'PATH_INFO';

Or other URI string.
Maybe works. Wink
Reply

#4
Did you try $config['base_url'] = 'https://yourdomain.name/';?
Reply

#5
It is an Apache server, right? Must be server misconfiguration. Apparently your server has a different way to work on his SSL port, and is ignoring the '.htaccess' file. You need to check if the application directory has permission to use the '.htaccess' file to rewrite urls. Well, on Apache server, you just need to set "AllowOverride All" in SSL mode too. I put a global defnition to Apache like this:

Code:
<Directory "/var/www/my-app-dir">
Options Indexes FollowSymLinks Multiviews
AllowOverride All
Order allow,deny
allow from all
</Directory>

Wink
Reply

#6
Get rid of this line you do not need it

RewriteCond $1 !^(index\.php|resources|robots\.txt)
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#7
Hello,

hey did u solve your probleme? let me know plz and how u did it?
Reply

#8
Change in config.php file:

$config['uri_protocol'] = 'PATH_INFO';

try this and let me know i will help you
Reply

#9
(06-23-2016, 10:31 PM)Code4fun Wrote: Did you  try $config['base_url'] = 'https://yourdomain.name/';?

Yes I have tried for my domain "Thanksgiving wishes"
But It's not working.
Reply

#10
(06-23-2016, 07:47 PM)tsuchiya Wrote: Hello,

Change in config.php file:

$config['uri_protocol'] = 'PATH_INFO';

Or other URI string.
Maybe works. Wink



Yes This is also working for my "2017 Calendar with holidays" Trip Plan.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.