• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
404 Error on new domain

#1
Hi All,

I know this has been posted a few times ive searched all the related threats/stackoverlfow/quora and no solutions have helped me.

I added a sub domain to a main domain to test my CI application. I copied over the database as well as all CI files to my new sub domain, made sure the database.php and config.php files were all adjusted correctly etc. 

My issue is that i cannot reach any of my views except index.php, the other views files for example contact.php, about.php etc are return a 404 error. I enabled debugging but unfortunately that did not help. 

my routes look identical for both index.php and my other view php files, what am i missing? i dont want to waste anyones time but i had no idea what else to try.

Thank you in advance
Reply

#2
Sounds like you are missing your .htaccess file?

I have seen hosting providers that have configured their FTP server to hide files starting with a dot in the filename. If you have copied all files from your main domain to the subdomain (for development I assume) you could be missing this file.
Reply

#3
(12-20-2016, 02:24 AM)Diederik Wrote: Sounds like you are missing your .htaccess file?

I have seen hosting providers that have configured their FTP server to hide files starting with a dot in the filename. If you have copied all files from your main domain to the subdomain (for development I assume) you could be missing this file.

So if i do add my htaccess file what should i put inside? Or there doesnt need to be anything there? Ive only really worked with htaccess for WP speed optimization.
Thanks you for your reply diederik 
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.