• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PROBLEM WHEN SAVING DATA FROM MY FORMS TO DB

#1
hello!
i've my app running correctly long ago.
but since yesterday, i when a push the save button, my data are not stored in the DB (mysql).
with the forms of my app, i can't perform successfully data insertion via POST, but all GET method works fine.
the app works fine too.
i've checked and it's not DB problem.

this is the ERROR log of my apache.


[Wed Apr 05 07:13:30.531081 2017] [core:error] [pid 3376:tid 876] (20024)The given path is misformatted or contained invalid characters: [client ::1:49408] AH00127: Cannot map GET /dgiparcauto/%3Casset/js/global/jquery.min.js HTTP/1.1 to file, referer: http://localhost/dgiparcauto/admin/mission/add_mission

[Wed Apr 05 07:14:04.229009 2017] [core:error] [pid 3376:tid 876] (20024)The given path is misformatted or contained invalid characters: [client ::1:49410] AH00127: Cannot map GET /dgiparcauto/%3Casset/js/global/jquery.min.js HTTP/1.1 to file, referer: http://localhost/dgiparcauto/admin/mission/manage_mission

this is the ERROR log of my apache.

[04/Apr/2017:23:55:12 +0000] "GET /dgiparcauto/%3Casset/js/global/jquery.min.js HTTP/1.1" 403 339
[04/Apr/2017:23:55:13 +0000] "GET /dgiparcauto/admin/mission/%3Ehttp://localhost/dgiparcauto/%3Casset/js/jquery-
                                               1.9.1.min.js HTTP/1.1" 404 1180
[04/Apr/2017:23:55:38 +0000] "POST /dgiparcauto/admin/mission/save_mission/ HTTP/1.1" 302 -
[04/Apr/2017:23:55:38 +0000] "GET /dgiparcauto/admin/mission/manage_mission HTTP/1.1" 200 51112
[04/Apr/2017:23:55:38 +0000] "GET /dgiparcauto/js/css3-mediaqueries.js HTTP/1.1" 404 1180


need help please !!


Attached Files Thumbnail(s)
       
Reply

#2
If your app has always been working, then something on your hosting has been changed.
Reply

#3
It log indicates that the server cannot find any of the javascript files that have been requested. Perhaps they have been deleted or the folder structure has changed so the expected path to the files no longer exists.
Reply

#4
check your html's <script src=""> I beleive its there. plus don't use localhost as part of your url. If your script is located at asset folder do something like <script src="asset/script.js"></script>
God Bless CI Contributors Smile
Reply

#5
ok i'll try
thank you
Reply

#6
%3C is a less than character "<". That's what the error is telling you, because the URL contains one before "asset".
Reply

#7
(04-05-2017, 09:25 AM)skunkbad Wrote: %3C is a less than character "<". That's what the error is telling you, because the URL contains one before "asset".

thank you, I've made some changes, according to your suggestions
now some errors do not appear .

::1 - - [06/Apr/2017:09:38:43 +0000] "GET /dgiparcauto/admin/mission/add_mission/28 HTTP/1.1" 200 115158
::1 - - [06/Apr/2017:09:39:39 +0000] "POST /dgiparcauto/admin/mission/save_mission/28 HTTP/1.1" 302 -

therefore forms data still not saved in db, and i think it seems to be a js conflict

i suspect these one as i use a form-hide-show script in my forms.

<script src="<?php echo base_url(); ?>asset/js/global/jquery.min.js"></script>
<script src="<?php echo base_url(); ?>asset/js/jquery-1.9.1.min.js"></script>
<script src='<?php echo base_url(); ?>asset/js/form-show/jquery.formShowHide.min.js'></script>

need help to solve it
Reply

#8
[quote pid='342320' dateline='1491474769']
<script src="<?php echo base_url(); ?>asset/js/global/jquery.min.js"></script>
<script src="<?php echo base_url(); ?>asset/js/jquery-1.9.1.min.js"></script>

I apologize for my English ... Do not you think that these files duplicate each other?

[/quote]
Reply

#9
(04-06-2017, 06:18 AM)hipm Wrote: [quote pid='342320' dateline='1491474769']
<script src="<?php echo base_url(); ?>asset/js/global/jquery.min.js"></script>
<script src="<?php echo base_url(); ?>asset/js/jquery-1.9.1.min.js"></script>

I apologize for my English ... Do not you think that these files duplicate each other?

[/quote]

ok, when i remove these two files or one of them, my app donc work properly. i've used their CND but the problem persist.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.