• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to use session

#11
it could be a server side cache thing (varnish for example). Does a simple standalone test file with some native php session work?
Reply

#12
(06-09-2017, 02:43 AM)Krycek Wrote: When you change page, do you go from http://www to http://, if so that could be a reason why your session is lost.

To quote myself, did you check this ?
Reply

#13
Here is how to autoload it in ./application/config/autoload.php

PHP Code:
/*
| -------------------------------------------------------------------
|  Auto-load Libraries
| -------------------------------------------------------------------
| These are the classes located in system/libraries/ or your
| application/libraries/ directory, with the addition of the
| 'database' library, which is somewhat of a special case.
|
| Prototype:
|
|    $autoload['libraries'] = array('database', 'email', 'session');
|
| You can also supply an alternative library name to be assigned
| in the controller:
|
|    $autoload['libraries'] = array('user_agent' => 'ua');
*/
$autoload['libraries'] = array(
    
'database',
 
   'session',
); 
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#14
I find the reason. I loose 3 weeks because of that so I write maybe that could help other.

I open a source with ftp and the libreoffice was taken as source editor. I think it destroy completely config.php

what I did I reinstall completement all sources and my sessions works well. Probably I had hidden characteres in source files.

Sorry for disturbing. It was actually not a codeigniter problem.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
3 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.