• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Anyone run CI 3.1.5 on Ubuntu 16.04

#1
Hi all

I'm curious if anyone actually runs CI 3.1.5 on Ubuntu 16.04 and any issues? Im still busy
with my projects on Ubuntu 14.04 but soon will migrate to that 16.04 or latest stable 

Appreciate if anyone gives me insight of the deployment on it

Thanks
Reply

#2
$ php -v
PHP 7.1.8-1+ubuntu17.04.1+deb.sury.org+1 (cli) (built: Aug 3 2017 18:38:39) ( NTS )

$ mysql --version
mysql Ver 14.14 Distrib 5.7.19, for Linux (x86_64) using EditLine wrapper

The important factors for your migration is the targeted PHP version and (most probably) the targeted MySQL version. CodeIgniter 3.1.5 alone has no compatibility issues, but your applications might have some small ones. Just install on your development machine a site you would need to upgrade, run it, and check for error/warning messages - missing extensions, deprecated features, warnings about stricter coding, etc. Corrections within code, if needed, would be mostly trivial. It would be nice, if you preliminary have a look at the changelogs of PHP and MySQL. Target at PHP 7.x, you will have more speed and less memory used.
Reply

#3
Thanks Ivan
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.