• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
remove index.php problem

#1
I was working on a project where everything seems to be working fine, database access is good, pages show correctly, and all that good stuff.

Now we're trying to remove index.php from the url, and we can't.  Just completely cannot remove it no matter what we look at, no matter where we search, nothing seems to be able to remove the index.php.

We're running apache on a Windows 10 development machine httpd.conf shows:
LoadModule rewrite_module modules/mod_rewrite.so
without any preceding #, so we know it's loading correclty (yes, we restarted the Apache server just to be sure)

Our development environment is located at:
  http://localhost/ci/
Or at least a "virgin" development environment, we chose to start from scratch on a clean CI install to make sure anything else we had done wasn't affecting the removal of index.php.

At present, 
  http://localhost/ci/
loads the default welcome page
  http://localhost/ci/index.php
shows it as well
  http://localhost/ci/welcome
shows 
Quote:Not Found

The requested URL /ci/welcome was not found on this server.

Our .htaccess has been a variety of the following:
Code:
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
Code:
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php?$1 [L]
Code:
Options +FollowSymLinks
Options -Indexes
DirectoryIndex index.php
RewriteEngine on
RewriteCond $1 !^(index\.php|images|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /ci/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /ci/index.php [L]
</IfModule>

and a few other variations.

Again, we're talking about Apache 2.4, Windows 10, php5

phpinfo shows mod_rewrite as a Loaded Module in the apache2handler

Any suggestions would be very greatly appreciated!

Ray
Reply

#2
Sounds like you need to search for "AllowOverride" in your Apache config and change all instances so they are "All" instead of "None".
Reply

#3
(09-28-2017, 05:23 PM)skunkbad Wrote: Sounds like you need to search for "AllowOverride" in your Apache config and change all instances so they are "All" instead of "None".

That was it, for all the searching we did, I'm glad I decided to pop in here and ask for some help.

Thank you very much!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.