• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
is this migration bug?

i just create migration by using CLI command

php spark migrate:create MoveFrameworkVersion

and look like everything work fine

C:\Users\pakkapon\Documents\Github\kotatsu-ci4>php spark migrate:create MoveFrameworkVersion

CodeIgniter CLI Tool - Version 4.0.0-alpha.3 - Server-Time: 2018-12-09 03:55:38am

Created file: App/Database/Migrations/20181209035538_MoveFrameworkVersion.php

but when i have to run migration using comamnd

php spark migrate:version 20181209035538

and error occur

C:\Users\pakkapon\Documents\Github\kotatsu-ci4>php spark migrate:version 20181209035538

CodeIgniter CLI Tool - Version 4.0.0-alpha.3 - Server-Time: 2018-12-09 03:56:01am

Migrating to version 20181209035538...
An uncaught Exception was encountered

Type:        TypeError
Message:     Argument 1 passed to CodeIgniter\Database\MigrationRunner::version() must be of the type integer, string given, called in C:\Users\pakkapon\Documents\Github\kotatsu-ci4\system\Commands\Database\MigrateVersion.php on line 129
Filename:    C:\Users\pakkapon\Documents\Github\kotatsu-ci4\system\Database\MigrationRunner.php
Line Number: 189

even i don't chance any line of code after create migration file. i still get this error? how can i fixed it?

PS. This is my pc info

 - OS: Windows 10 (1809)
 - Web server: Apache 2.4.34
 - PHP version:  7.1.20

Thank you.

It's defined as a string in the function parameters. What happens if you enclose it in quotes?
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )

It still doesn't work.
C:\Users\pakkapon\Documents\Github\kotatsu-ci4>php spark migrate:"20181209035538"

CodeIgniter CLI Tool - Version 4.0.0-alpha.3 - Server-Time: 2018-12-09 21:25:29pm

Command 'migrate:20181209035538' not found

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.