• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Database connection issues

#1
Hey eveyone!

Im having issues connecting CI to database. I have a feeling some of it is due to my wbehost but was wondering if some of it was due to configuration mistake on my end. Ive attached a screenshot but if that doesnt open here it is:

A PHP Error was encountered
Severity: Warning
Message: mysqli::real_connect(): (28000/1045): Access denied for user 'cpses_cuzpghfnyu'@'localhost' (using password: YES)
Filename: mysqli/mysqli_driver.php
Line Number: 203
Backtrace:
File: /home4/cultured/public_html/index.php
Line: 315
Function: require_once
A PHP Error was encountered
Severity: Warning
Message: Cannot modify header information - headers already sent by (output started at /home4/cultured/public_html/system/core/Exceptions.php:271)
Filename: core/Common.php
Line Number: 564
Backtrace:
File: /home4/cultured/public_html/index.php
Line: 315
Function: require_once
A Database Error Occurred
Unable to connect to your database server using the provided settings.
Filename: core/CodeIgniter.php
Line Number: 518

Thank you for any help given!

Heart Heart ,
Mekaboo


Attached Files Thumbnail(s)
   
Reply

#2
@Mekaboo,

You need to check some things. Make sure that your php settings have MySQL extension turned on. Also, you should talk with your host company to make sure that you have the correct DB settings.
Reply

#3
@Mekaboo,

Also, what version of CI are you using? PHP version?
Reply

#4
(04-14-2019, 05:41 PM)php_rocs Wrote: @Mekaboo,

Also, what version of CI are you using?  PHP version?

Thank ya so much for the advice Heart
Im using the current version of CI and web host uses version 5.4
Reply

#5
After speaking with my webhost I realized I a few mistakes with the credentials in my database.php file. Got them fixed!!
Reply

#6
@Mekaboo,

Glad I could help. One other recommendation. I'm surprised that your hosting company is still using PHP 5.4. PHP 5.4.x is EOL ( https://www.php.net/eol.php ) They should at least be 7.1.x.
Reply

#7
(04-15-2019, 09:00 AM)php_rocs Wrote: @Mekaboo,

Glad I could help.  One other recommendation.  I'm surprised that your hosting company is still using PHP 5.4.  PHP 5.4.x is EOL ( https://www.php.net/eol.php ) They should at least be 7.1.x.

And 7.1 will reach End of Life on 1 December 2019.
Reply

#8
(04-15-2019, 09:00 AM)php_rocs Wrote: @Mekaboo,

Glad I could help.  One other recommendation.  I'm surprised that your hosting company is still using PHP 5.4.  PHP 5.4.x is EOL ( https://www.php.net/eol.php ) They should at least be 7.1.x.

Im actually building a site for a client and the webhost they chose hasn't updated their php I guess. The webhost I use personally recently sent me an email to update my php so I will be doing that ASAP!!!
Reply

#9
(04-15-2019, 01:30 PM)dave friend Wrote:
(04-15-2019, 09:00 AM)php_rocs Wrote: @Mekaboo,

Glad I could help.  One other recommendation.  I'm surprised that your hosting company is still using PHP 5.4.  PHP 5.4.x is EOL ( https://www.php.net/eol.php ) They should at least be 7.1.x.

And 7.1 will reach End of Life on 1 December 2019.

I have a feeling when the webhost inform my client of the change they will inform me. The webhost I use for myself has already informed me of the update so I will be doing that soon!!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.