• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Migrating CI3 to CI4

#1
Hi,

I am running a CI site with version 3.0.4 and MySQL 5.5 - SSD.

Currently exploring options to update the entire site to CI 4.0.4 to allow us to run PHP 7.2 and MySQL 8.0 (if possible).

We have a pretty clean installation which can be provided. There is no need for design changes.

Additionally used are: jQuery 1.1.12 Bootstrap 3.3.6 DataTables 1.10.10 FontAwesome 4.0.5 TinyMCE 4.3.7 Fileinput 4.2.7

Scope of work:

1) Move CI to Version 4 while ensuring all components/features are retained

2) Update/test and optimise any JS that should needs updating

Bonus: 3) if possible change payment gateway from standard PayPal to PayPal Plus (Germany), no storage of payments in DB required. Simple processing only.

The project is not urgent. Feel free to quote or ask questions if you are interested, will provide website if you message me. Budget depends on quote.
Reply

#2
Hi Marwin,
Sounds like an interesting concept and something that is right up my alley of expertise.
I would be interested in helping you with your needs.
You can reach me on anna(dot)cis23(at)gmail(dot)com or Skype:cis.am2 for a formal quotation.
Very Best Regards,
Anna J
Reply

#3
Hello Marwin ,
I had sent you PM. Please check
Interested further to assist on Migration

Awaiting reply

Regards
Deep
Reply

#4
(11-01-2020, 11:45 PM)marwin Wrote: I am running a CI site with version 3.0.4 and MySQL 5.5 - SSD.

Currently exploring options to update the entire site to CI 4.0.4 to allow us to run PHP 7.2 and MySQL 8.0 (if possible).

Just so you know, you can also upgrade your CI 3.0.4 to 3.1.11. It is compatible with PHP 7.
I maintain an application that run without problems on PHP 7.3.
https://codeigniter.com/userguide3/gener...ments.html
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
Reply

#5
(11-04-2020, 03:41 PM)includebeer Wrote:
(11-01-2020, 11:45 PM)marwin Wrote: I am running a CI site with version 3.0.4 and MySQL 5.5 - SSD.

Currently exploring options to update the entire site to CI 4.0.4 to allow us to run PHP 7.2 and MySQL 8.0 (if possible).

Just so you know, you can also upgrade your CI 3.0.4 to 3.1.11. It is compatible with PHP 7.
I maintain an application that run without problems on PHP 7.3.
https://codeigniter.com/userguide3/gener...ments.html

Thanks for the tip! This seems indeed to be more of a viable solution. For standard application I wont run into issues with MySQL 8? Currently running 5.5. with mysqli as dbdriver.

Upgrading to 3.1.11 seems like a walk in the park if the system folder has not been touched. I only have to two customised files there and we dont use any of the functions mentioned in the upgrade path. Do you go straight to 3.1.11 or do I go step by step?
Reply

#6
I don’t know about MySQL 8. The CI3 web apps I maintain on PHP7 uses Oracle.

For upgrading, I recommend reading the instructions from one version to the other, but just copy the system folder at the end from the 3.1.11 version.

http://codeigniter.com/userguide3/instal...ading.html
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
Reply

#7
(11-05-2020, 04:26 PM)includebeer Wrote: I don’t know about MySQL 8. The CI3 web apps I maintain on PHP7 uses Oracle.

For upgrading, I recommend reading the instructions from one version to the other, but just copy the system folder at the end from the 3.1.11 version.

http://codeigniter.com/userguide3/instal...ading.html

thanks I will do that. already checked through and could not find anything. will create a clone for my setup to try out. could not find anything that would affect me - none of the functions mentioned in the upgrade path are used on my site.
Reply

#8
Perfect, then it will be super easy! Smile
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.