• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI 4 not working

#1
i downloaded CI using this link: https://codeigniter.com/download 

when I run on XAMP below error appear. 


Fatal error: Uncaught Error: Call to undefined function CodeIgniter\locale_set_default() in C:\xampp\htdocs\jsforsociety\system\CodeIgniter.php:184 Stack trace: #0 C:\xampp\htdocs\jsforsociety\system\bootstrap.php(181): CodeIgniter\CodeIgniter->initialize() #1 C:\xampp\htdocs\jsforsociety\public\index.php(36): require('C:\\xampp\\htdocs...') #2 {main} thrown in C:\xampp\htdocs\jsforsociety\system\CodeIgniter.php on line 184

how to solve?
Reply

#2
@Jeewakapk
> how to solve?

Try searching this forum for locale_set_default

https://forum.codeigniter.com/search.php...order=desc
Reply

#3
Thank you so much.

next time i will search as you told.

I am new to CI

Appreciate your reply
Reply

#4
look in xampp\php\php.ini

try change ;extension=intl to extension=intl

in theory with xampp you are probably using some form of Linux ? since from memory windows is wamp or similar.
There are a few options for developing CI4 if you have Linux .

Simply use apache on Linux , better than xampp

Just put Dev directory on desktop and use spark serve to fire up dev http services; use sqlite for database

use free live web hosting such as 000webhost
Reply

#5
And make sure that you are running php 7.2 +
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#6
(11-03-2020, 02:32 AM)captain-sensible Wrote: look in  xampp\php\php.ini

try change  ;extension=intl to extension=intl

in theory with xampp you are probably using some form of Linux ? since from memory windows is wamp or similar.
There are a few options for developing CI4 if you have Linux .

  Simply use apache on Linux , better than xampp

  Just put Dev directory on desktop and use spark serve to fire up dev http services; use sqlite for database

  use free live web hosting such as 000webhost
thank you for so much advise

(11-03-2020, 09:46 AM)InsiteFX Wrote: And make sure that you are running php 7.2 +
will do
Reply

#7
@Jeewakapk always nice to get feed back how are you progressing with it ?
Reply

#8
thank you so much. still not tried. will update you.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.