CodeIgniter Forums

Full Version: [SOLVED]Problem with a3m OpenId on server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

El Forum

[eluser]Lucian_bz[/eluser]
The problem was solved.

I'll leave this topic here because those who encounter this problem to know what happens.

The error that appears a3m but does not specify exactly the problem.

With luck, other libraries have been testing and i receive more intelligible error message:

Code:
It was not enable CURLssl.

In conclusion:

You need to compile apache with CURLssl's not just simply curl, otherwise the server will not know how to work with HTTPS URLs.

The solution was obvious but received an error generalist just realized I did not.

phpserver, thanks for your interest and help.

Sincerely,
Lucian



Hi everyone,

I have a problem it did manage to find the best solution after hours of searching the Internet and server tests. Maibe someone can help me.

I've downloaded and tested a3m local place and work perfectly.

When i put on the server i get an error when i try to log-in with OpenID from Yahoo.

The error is:

Fatal error: Call to a member function addExtension() on a non-object in /home/orasele/public_html/system/application/modules/account/controllers/connect_yahoo.php on line 126

It can be seen at http://orasele.ro

There are some dependencies needed on the server for this library?

Server is on VPS, not shared hosting, with Centos 5 and whm/cpanel instaled.

Thanks in advance.

Sincerely,
Lucian

El Forum

[eluser]phpserver[/eluser]
Probably something to do with your php version.

El Forum

[eluser]Lucian_bz[/eluser]
Is the same php version on both: local and server: 5.2.9 ...

El Forum

[eluser]phpserver[/eluser]
Could you paste the connect_yahoo.php here: http://cssdoll.ietherpad.com/1? or anywhere where we can see the file?.

El Forum

[eluser]Lucian_bz[/eluser]
Of course:

http://www.pasteit4me.com/2236001

Is the original file without any modify.

Maibe will be required additional file to see where is the problem because at this line is only load the class and call the function ...

Thank-you.

El Forum

[eluser]phpserver[/eluser]
I'll setup my vps tonight and get back to you; I am running ubuntu 10.

El Forum

[eluser]Lucian_bz[/eluser]
Thank-you verry much, i will be here.

El Forum

[eluser]phpserver[/eluser]
Works fine with xampp;tested it on Ubuntu 10 with the https that comes with xampp.Nowadays you can login to yahoo using google which is a little confusing.

El Forum

[eluser]phpserver[/eluser]
Anytime mate.

El Forum

[eluser]Peng Kong[/eluser]
thanks phpserver.

im using window7 xampp for a3m development.

p.s. i'm moving to ubuntu10.10 too (:
Pages: 1 2