CodeIgniter Forums

Full Version: preg_match error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]caen[/eluser]
I have just installed CodeIgniter 2.0.2 on PHP 5.4 alpha 2, and I get the following
Code:
Severity: Warning
Message: preg_match() [function.preg-match]: Compilation failed: unknown option bit(s) set at offset 0
Filename: core/Utf8.php
Line Number: 44

Is it related to how I have compiled PHP, or is it related to CodeIgniter? Thanks!

El Forum

[eluser]Aken[/eluser]
It appears that you have an unsupported version of PCRE built into your PHP. Most things I've read while doing a quick search says the best solution is to recompile PHP with the appropriate PCRE.

http://stackoverflow.com/questions/21068...port-utf-8

El Forum

[eluser]caen[/eluser]
Thank you for your reply!