CodeIgniter Forums

Full Version: CKEditor Javascript Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]seminalJim[/eluser]
Hi guys,

Ive just installed CKEditor on my CI site, and after some tweaking it works great.
Thing is however when i upload to server, and test it online it doesnt work.

I get the textarea, but its not changed to CK.

I used firebug's javascript profiler and it says:

"NetworkError: 404 Not Found - http://www.snapse.net/javascript/ckeditor/ckeditor.js"

Im not sure, but im guessing it may be something to do with access to that file or folder as when I type in into the url i get...

404 Page not Found

My .htaccess file is so...

Code:
SetEnv MAGIC_QUOTES 0
SetEnv PHP_VER 5
Options +FollowSymlinks -MultiViews
RewriteEngine On
DirectoryIndex index.php
RewriteCond %{REQUEST_URI} ^system.*
RewriteRule (.*) index.php?/$1 [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond $1 !^(index\.php|image|robots\.txt|css)
RewriteRule (.*) index.php?/$1 [L]

I know nothing of how this works, I just copied it from site.

El Forum

[eluser]michalsn[/eluser]
Change:
Code:
RewriteCond $1 !^(index\.php|image|robots\.txt|css)
to:
Code:
RewriteCond $1 !^(index\.php|javascript|image|robots\.txt|css)

El Forum

[eluser]CroNiX[/eluser]
Actually, remove that line entirely. All real files and directories will be ignored by CI and are covered by the 2 previous lines (-F, -D), so this is doing nothing but getting in the way.

Code:
RewriteCond $1 !^(index\.php|image|robots\.txt|css)

If you're using CI2+, these lines are also doing nothing as the system directory has it's own htaccess preventing direct access:
Code:
RewriteCond %{REQUEST_URI} ^system.*
RewriteRule (.*) index.php?/$1 [L]

So really, this is all you should need:
Code:
SetEnv MAGIC_QUOTES 0
SetEnv PHP_VER 5
Options +FollowSymlinks -MultiViews
RewriteEngine On
DirectoryIndex index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php?/$1 [L]