CodeIgniter Forums

Full Version: Possible cache error ?? (changes made to code on the server does not reflect immediately)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]ebuoe[/eluser]
i have been using codeigniter for quite some time now but i havent experienced anything like this , after i upload to the server , i visit the page , make minor changes but this does not reflect immediately , and the changes are required to test what i'm doing .

So my question :
Is this a cache issue ??

because i'm not even using codeigniter's cache library and i even cleared the cache and n browsing history on my browsers and also tried visiting from other devices.

If the problem s cache is there a way i could disable this during development phase?

El Forum

[eluser]TWP Marketing[/eluser]
It could also be your browser cache. Flush it and reload the view to test.

El Forum

[eluser]CroNiX[/eluser]
What does a hard refresh, which bypasses the browser cache, in your browser do? (CTRL+F5)

Define "does not reflect immediately". How long does it take? Is it consistent?

El Forum

[eluser]ebuoe[/eluser]
i always clear the cache before refreshing , bt it still takes time (30 mins) to reflect , let me also add that this only happens on the remote server , bt i have no problems on my local

El Forum

[eluser]Unknown[/eluser]
i have some problem.. previosly version of codeigniter no problem.

El Forum

[eluser]TWP Marketing[/eluser]
[quote author="ebuoe" date="1347004330"]i always clear the cache before refreshing , bt it still takes time (30 mins) to reflect , let me also add that this only happens on the remote server , bt i have no problems on my local[/quote]

That sounds like caching on the remote server itself, not by your browser. Check the server configuration.