CodeIgniter Forums

Full Version: SQL Server Error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey Guys,

I'm trying to configure a WISP installation.  I have downloaded the appropriate SQL Server PHP Extension for Windows and i'm using the sqlsvr driver in CodeIgniter.  I'm not getting any connection errors, but I am getting the following error:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 65488 bytes) in D:\webapps\ci-3.0.0\database\DB_driver.php on line 147

I have upped the memory limit in php.ini from 128 mb to 256 mb, but that didn't seem to fix it, just gave me the same error.  This is also a brand new installation, so all i've done is download CodeIgniter with just the welcome controller, and have not added any database code. I get the error when I try to add the 'database' option to the autoload array.

Any ideas?

Thanks,

Lee
Line 147 is a comment block ...
(05-06-2015, 06:12 PM)jlq10 Wrote: [ -> ]Hey Guys,

I'm trying to configure a WISP installation.  I have downloaded the appropriate SQL Server PHP Extension for Windows and i'm using the sqlsvr driver in CodeIgniter.  I'm not getting any connection errors, but I am getting the following error:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 65488 bytes) in D:\webapps\ci-3.0.0\database\DB_driver.php on line 147

I have upped the memory limit in php.ini from 128 mb to 256 mb, but that didn't seem to fix it, just gave me the same error.  This is also a brand new installation, so all i've done is download CodeIgniter with just the welcome controller, and have not added any database code.  I get the error when I try to add the 'database' option to the autoload array.

Any ideas?

Thanks,

Lee
i have the same problem with c1.3.1.9 !

any suggestion ?


thanks
I'm using the standaard sqldrv with mussel 2014 and 2016 with no problem.


Code:
$db['default'] = array(
    'dsn'    => '',
    'hostname' => 'name server\SQLEXPRESS',  //if you using sqlexpress like me
    'port' => '1433',
    'username' => 'your username',
    'password' => 'your password',
    'database' => 'Your database',
    'dbdriver' => 'sqlsrv',
    'dbprefix' => '',
    'pconnect' => FALSE,
    'db_debug' => (ENVIRONMENT !== 'production'),
    'cache_on' => FALSE,
    'cachedir' => '',
    'char_set' => 'utf8',
    'dbcollat' => 'utf8_general_ci',
    'swap_pre' => '',
    'encrypt' => FALSE,
    'compress' => FALSE,
    'stricton' => FALSE,
    'failover' => array(),
    'save_queries' => TRUE
);
Hello,

I got your problems. I have one solution for that hopefully it will help you.

Change the memory_limit option in your php.ini as per your needs. or script on a live server then contact to your server provider, for  Change memory limit options.