CodeIgniter Forums

Full Version: 3.0 Stable and DB2 - Bare PHP Works with ODBC, CI Is Not...help?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Using bare php with the pdo odbc connection method, and having the DB2 connector installed, I can connect and query just fine, using this DSN:

odbcBig GrinRIVER={iSeries};SYSTEM=localhost;PROTOCOL=TCPIP;DATABASE=TEST

Using the same DSN in Codeigniter, with pdo, I am apparently able to connect, but any time I run any queries, I get 0 results when I should be getting many, and also find that the query itself seems to be having the parameters removed from it (if I echo last_query they appear empty).

Can anybody shed some light on what I or CI is doing wrong? At this point I'm not sure which it is.

I know that DB2 can be odd, but since I've prototyped the functionality in vanilla php that I'm looking to replicate in Codeigniter, I suspect I'm missing something subtle in my configuration, or that something is broken in the codeigniter code.

Any and all help is appreciated. Thanks!
Ok, so even loading up the class I wrote, that works in vanilla php, in CI, I am making the connection, but still getting 0 results.

Does CI do something under the hood, or overload some native php functions that would cause this?
It appears that my parameters are being replaced with empty ticks ... ''

Seems to be a bug?
hello mpdmp,

How you configure your codeigniter to accesto DB2 IBM pleeeeease ?