CodeIgniter Forums

Full Version: request in CLI missing URI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
hi,
i searched a lot and i'm surprised not to find so i dare request some help here...

for my crons i used to do
Code:
php5.5 -q $HOME/dir/www/index.php contact relance_auto
where contact is the controller and relance_auto is the method as given in documentation.
it worked fine with CI 2.2

but the same doesn't work with CI 3.0.3 and in the log i have :
Code:
No URI present. Default controller set.

i feel dumb loosing a lot of time on this problem as i am obviously alone to have it.
has anyone something to suggest ?

(please excuse my bad english)
Is "php5.5" the php-cli binary? You may be using another SAPI.
(01-06-2016, 12:11 PM)Narf Wrote: [ -> ]Is "php5.5" the php-cli binary? You may be using another SAPI.

you are right "php5.5" is not the php-cli binary, i have to call "php5.5-cli" and it works with CI 3.0.3.
thank you very much, I'm sorry disturb you.
problem solved.