CodeIgniter Forums

Full Version: Operation aborted in IE6
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]JMLWeb[/eluser]
Hello, I got an error when I enter to my page (http://www.jmlweb.es), but only in IE6.
I´m going crazy, please, help me!

Here are htaccess code:

Quote:RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
RewriteRule portafolio-(.*).html portafolio/pagina/$1
RewriteRule portafolio/tipo/diseno-web-(.*).html portafolio/tipo/diseno-web/$1
RewriteRule portafolio/tipo/programacion-web-(.*).html portafolio/tipo/programacion-web/$1
RewriteRule portafolio/fecha/(.*)-(.*).html portafolio/fecha/$1/$2
RewriteRule portafolio/cliente/(.*)-(.*).html portafolio/cliente/$1/$2
RewriteRule portafolio/tecnologia/(.*)-(.*).html portafolio/tecnologia/$1/$2

El Forum

[eluser]Rascal2pt0[/eluser]
Is this the operation aborted IE error page, or the operation aborted popup dialogue?

If its the later its because your page is trying to access the DOM before its completly loaded and adding an onload event to the body will fix it. Otherwise I have no idea.

El Forum

[eluser]JMLWeb[/eluser]
The error is an operation aborted popup dialogue. I use following javascript libraries:

_Mootools -> I use the 'domready' envent
_Reflex.js -> A library for creating js reflection in images

El Forum

[eluser]Rascal2pt0[/eluser]
If you aren't already I would try and make Reflex.js load from the Mootools domready event. If that can't fix it I don't know how to proceed other than googling for the error.

El Forum

[eluser]JMLWeb[/eluser]
Solved:

In the reflex.js library FAQ:

Internet Explorer doesn't like the open <base> tag. Do the following: Exchange...
<base href="http://www.yourdomain.com/">
...or...
<base href="http://www.yourdomain.com/" />
...with...
&lt;base href="http://www.yourdomain.com/"&gt;&lt;!--[if IE]>&lt;/base&gt;<![endif]--&gt;
...and you're good.

El Forum

[eluser]Rascal2pt0[/eluser]
gotcha. I've never used the base tag so I wouldn't have even thought of it.