CodeIgniter Forums

Full Version: Tutorial
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Smile

I am totally new to CodeIgniter, but seems a very nice PHP Framework.  Just did the tutorial, and may sounds strange but something bad happened.  Just followed the instruction, understood what i need to do, what connectors, etc does, but after did create function, getting errors, which is strange.

My baseurl is: localhost/ci cause all CodeIgniter put in my htdocs/ci directory.

However, after creating an article seems URL having a problem:

http://localhost/ci/index.php/news/localhost/ci/index.php/news/create

even tried just localhost, but same happened.. 

any idea? if you need any part of code, just ask, so i gonna provide pastebin copy Smile
(04-08-2016, 08:37 AM)sqpp Wrote: [ -> ]Hello Smile

I am totally new to CodeIgniter, but seems a very nice PHP Framework.  Just did the tutorial, and may sounds strange but something bad happened.  Just followed the instruction, understood what i need to do, what connectors, etc does, but after did create function, getting errors, which is strange.

My baseurl is: localhost/ci cause all CodeIgniter put in my htdocs/ci directory.

However, after creating an article seems URL having a problem:

http://localhost/ci/index.php/news/localhost/ci/index.php/news/create

even tried just localhost, but same happened.. 

any idea? if you need any part of code, just ask, so i gonna provide pastebin copy Smile



Try putting http:// before 'localhost' in your config file.