CodeIgniter Forums

Full Version: Basic App - Free CMS on CodeIgniter 4
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
Hi!
Installation went smoothly. I started to check code and to prepare for my test project. Not yet any customization.
Just made upgrade (composer) to CI 4.04 and faced some problems.

Latest one, local web server did not start.
---------------------
cmd>php spark serve

CodeIgniter CLI Tool - Version 4.0.4 - Server-Time: 2020-07-30 14:16:40pm

An uncaught Exception was encountered

Type:        TypeError
Message:    Argument 2 passed to BasicApp\Core\BaseCommand::__construct() must be an instance of CodeIgniter\CLI\CommandRunner, instance of CodeIgniter\CLI\Commands given, called in /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/Commands.php on line 157
Filename:    /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/basic-app/core/Core/BaseCommand.php
Line Number: 23

        Backtrace:
                                                -157 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/Commands.php::__construct
                                                                -86 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/Commands.php::discoverCommands
                                                                -107 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/CommandRunner.php::run
                                                                -85 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/CommandRunner.php::index
                                                                -914 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CodeIgniter.php::_remap
                                                                -404 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CodeIgniter.php::runController
                                                                -312 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CodeIgniter.php::handleRequest
                                                                -86 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/Console.php::run
                                                                -57 - /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/spark::run
(07-30-2020, 04:28 AM)ezis Wrote: [ -> ]An uncaught Exception was encountered

Type:        TypeError
Message:    Argument 2 passed to BasicApp\Core\BaseCommand::__construct() must be an instance of CodeIgniter\CLI\CommandRunner, instance of CodeIgniter\CLI\Commands given, called in /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/codeigniter4/framework/system/CLI/Commands.php on line 157
Filename:    /home/ubuntu/NetBeansProjects/development/panel/basic-app/demoapp/vendor/basic-app/core/Core/BaseCommand.php
Line Number: 23

Thanks! Fixed. Please run composer update command again.
Thanks a lot for this basic-app. However, it has stopped working since i updated to php 8.0
Problem 1
- basic-app/core is locked to version dev-master and an update of this package was not requested.
- basic-app/core dev-master requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 2
- laminas/laminas-escaper is locked to version 2.6.1 and an update of this package was not requested.
- laminas/laminas-escaper 2.6.1 requires php ^5.6 || ^7.0 -> your php version (8.0.2) does not satisfy that requirement.
Problem 3
- basic-app/core dev-master requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
- basic-app/theme-bootstrap4 dev-master requires basic-app/core * -> satisfiable by basic-app/core[dev-master].
- basic-app/theme-bootstrap4 is locked to version dev-master and an update of this package was not requested.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
Thanks for the info. We checked the system and came to the conclusion that it is completely inoperable with the current versions of the dependencies.

At the moment, our work is only on a few packages from the system, and it is difficult to predict when the system will work.
(02-17-2021, 01:35 AM)cocl Wrote: [ -> ]Thanks a lot for this basic-app. However, it has stopped working since i updated to php 8.0

Major bugs have been fixed, but haven't tested for php 8.
Pages: 1 2 3 4 5 6 7