CodeIgniter Forums

Full Version: pdo_msql.so
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everyone!!, sorry for my bad english

I have been trying to upgrade my webapps from php 5.6 to 7.2 on my host, but when I make the change the apps gives me the following error

A PHP Error was encountered
Severity: Core Warning
Message: PHP Startup: Unable to load dynamic library 'pdo_msql.so' (tried: /opt/cpanel/ea-php72/root/usr/lib64/php/modules/pdo_msql.so (/opt/cpanel/ea-php72/root/usr/lib64/php/modules/pdo_msql.so: cannot open shared object file: No such file or directory), /opt/cpanel/ea-php72/root/usr/lib64/php/modules/pdo_msql.so.so (/opt/cpanel/ea-php72/root/usr/lib64/php/modules/pdo_msql.so.so: cannot open shared object file: No such file or directory))
Filename: Unknown
Line Number: 0
Backtrace:

I already try find on php ini editor but i can't find the library, could you help me to fix this issue

Thansk to everyone

Regards!!!
Check to see if it is enabled in your php.ini file.

PHP Code:
<?php

// Show all information, defaults to INFO_ALL
phpinfo();

?>

Save as phpinfo.php | When your finished using it back  it and save it.

Do Not leave it on a live server!
(04-11-2019, 01:31 PM)InsiteFX Wrote: [ -> ]Check to see if it is enabled in your php.ini file.

PHP Code:
<?php

// Show all information, defaults to INFO_ALL
phpinfo();

?>

Save as phpinfo.php | When your finished using it back  it and save it.

Do Not leave it on a live server!

Hello again!!!, 
[font=arial, sans-serif]I already got the result of phpinfo and the following appeared, but i didn't found the line "pdo_msql.so", thanks again

[/font]
You misunderstood a bit InsiteFX.

You have to check if the line
Code:
extension=pdo_msql
exist and is activate in the "php.ini".


If you see
Code:
;extension=pdo_msql

that's means the module is deactivated.

But I also suspect a typo somewhere because it's seems very close to the module "pdo_mysql" with a Y, so I don't know.