CodeIgniter Forums

Full Version: POST input is empty if contains accented characters.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there folks.

I'm trying to debug a CI app to a friend of mine. The issue is that $this->input->post('name'); is empty if a accented character is sent.
Eg.:

If I send the name as Testing, then the value of $this->input->post('name'); is also Testing.
But if I send the name as Accentuátion (or anything with special accent characters), the the value of $this->input->post('name'); is "" (empty).

Any clue of what might be causing this issue of how to fix it?


Thanks!
(05-07-2019, 06:27 PM)fschuindt Wrote: [ -> ]Hi there folks.

I'm trying to debug a CI app to a friend of mine. The issue is that $this->input->post('name'); is empty if a accented character is sent.
Eg.:

If I send the name as Testing, then the value of $this->input->post('name'); is also Testing.
But if I send the name as Accentuátion (or anything with special accent characters), the the value of $this->input->post('name'); is "" (empty).

Any clue of what might be causing this issue of how to fix it?


Thanks!

fschuindt,

We need details! What version of CI are you using? What language settings are you using? What type of input field is being used? Are you using any 3rd party UI libraries for the input field? 

With answers to these I may be able to help.
Hello,
What do you have in $_POST['name'] ?
You can get it with:
var_dump($_POST['name']);