CodeIgniter Forums

Full Version: video tutorials and debug bar ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, 
I am new to CI : I have just basis of CI3

1) I could not really find any video tutorials (on lynda, video2brain, linkedlearning): is there a video tuto for CI4 available ?

2) I run CI on local apache with WAMP. How do I enable to debug bar ? I searched in /Config and could not find such parameters

Regards
Lonnie has some video tutorials on his Patreon page.

The debug bar should be enabled automatically in "development" mode. I don't have a link handy, but one of the other community members might.
Debug toolbar is enabled by default for development - likely you need to set your environment. Best bet is to rename (in the root) env to .env and uncomment and set CI_ENVIRONMENT to "development" (see also https://codeigniter4.github.io/CodeIgnit...ments.html).

On the off chance that it isn't an environment issue, the Toolbar config is located at app/Config/Toolbar.php and it is activated by app/Config/Events.php ("Debug Toolbar Listeners"). Good luck!
(06-26-2019, 07:23 AM)MGatner Wrote: [ -> ]Debug toolbar is enabled by default for development - likely you need to set your environment. Best bet is to rename (in the root) env to .env and uncomment and set CI_ENVIRONMENT to "development" (see also https://codeigniter4.github.io/CodeIgnit...ments.html).

On the off chance that it isn't an environment issue, the Toolbar config is located at app/Config/Toolbar.php and it is activated by app/Config/Events.php ("Debug Toolbar Listeners"). Good luck!

And here we go  Confused

I've done and checked all that points, Chrome Dev Tools shows that my pages are generating javascript stuff for the Toolbar, tings are "collected" but the presentation layer don't show up.

It seems like i'm getting a 500 more because of the cookie, the sessions or who knows what else.

As I never saw the Toolbar in action i can't say that i miss it ^^ but il would be nice to see it. The toolbar of Symfony is helpful, so i guess i'll enjoy the CI's one if i can.
You’re using an updated version of the framework code with an old config file. Make sure you have synched app/Config/App.php with the lates lt framework version - there have been updates, likely since you installed.
...aaand, the Toolbar is Aliiiive  Big Grin  my messy sandbox is happy to have stats. The exploration continue.

I have started with a fresh install, than put back in the bricks one by one to see if it breaks.
Nice job on that one, useful tool for sure.