CodeIgniter Forums

Full Version: CodeIgniter 4.0.0-rc.1 released
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
CodeIgniter-4.0.0-rc.1  launches today

This is a pre-release of 4.0.0. It is not suitable for production! (but it is pretty darn close)

Highlights:
  • Migrations refactored and streamlined for more wholistic functionality (BC)
  • CI3 Email ported to CI4
  • Encryption (basic) added
  • RESTful controllers added to shorten dev time for RESTful APIs
  • New messages for Migrations and RESTful

Check the changelog for details, and the installation writeup for further directions.

Looking to upgrade from CI3 to CI4?
Generated API docs accessible at https://codeigniter4.github.io/api/

This is our first release candidate! A number of things have been fixed, and it is looking pretty good Smile We need to know what remains in the way of hiccups!

Thank you to the community for stepping up to help make this the best PHP framework!

Do NOT post support questions or feature requests in response to this thread - those will be deleted. Instead, use the appropriate CodeIgniter 4 subforum. We are trying to make the best of the limited resources that we have!

Thank you, and ENJOY!
Soooooooo excited!
Congrats to the whole team!
Awesome. I can't wait to try the RESTful library. I've been waiting for this since 2.x.
Nice! Thanks to the CI team!
Can this version be used in production?
We just got a little bit closer. Watch out world...here we come.
Anyone more knowledgeable in composer that I am may point me in the right direction how to update a beta4 project to rc. Tried changing the require to 4@rc but no go.
(09-03-2019, 09:29 AM)byc0d3 Wrote: [ -> ]Can this version be used in production?

Officially, no.
Unofficially, many are already.
(09-03-2019, 11:19 AM)tgix Wrote: [ -> ]Anyone more knowledgeable in composer that I am may point me in the right direction how to update a beta4 project to rc. Tried changing the require to 4@rc but no go.

Are you talking about the appstarter, framework or devstarter?
The installation method is relevant to your update.
Pages: 1 2 3 4