CodeIgniter Forums

Full Version: trying CI4 but get ErrorException
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i installed ci4 with composer, but when i execute $php spark verse this show up.

An uncaught Exception was encountered

Type:        ErrorException
Message:    Required parameter $from follows optional parameter $verbs
Filename:    D:\XAMPP\htdocs\cites\vendor\codeigniter4\framework\system\Router\R
outeCollection.php
Line Number: 1017


what is the solution?
What php version are you running with xampp?
It looks like a PHP 8 error and CodeIgniter 4 is not fully compatible with PHP 8.

Check this: PHP: Deprecated Features - Manual