CodeIgniter Forums

Full Version: MacOS M1 can't install CodeIgniter 4, missing PHP's intl extension
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I install codeigniter 4 with MAMP, but I get error:

our requirements could not be resolved to an installable set of packages.
  Problem 1
    - codeigniter4/framework[4.0.0, ..., v4.1.3] require ext-intl * -> it is missing from your system. Install or enable PHP's intl extension.
    - Root composer.json requires codeigniter4/framework ^4 -> satisfiable by codeigniter4/framework[4.0.0, ..., v4.1.3].

I have tried adding extension=intl to php.ini, but it doesn't work.
Can you help me? Thank you.
(07-17-2021, 11:58 PM)carvellho Wrote: [ -> ]Hello, I install codeigniter 4 with MAMP, but I get error:

our requirements could not be resolved to an installable set of packages.
  Problem 1
    - codeigniter4/framework[4.0.0, ..., v4.1.3] require ext-intl * -> it is missing from your system. Install or enable PHP's intl extension.
    - Root composer.json requires codeigniter4/framework ^4 -> satisfiable by codeigniter4/framework[4.0.0, ..., v4.1.3].

I have tried adding extension=intl to php.ini, but it doesn't work.
Can you help me? Thank you.
[Solved]
(07-18-2021, 11:26 AM)carvellho Wrote: [ -> ][Solved]

Ok, what was the solution?