CodeIgniter Forums

Full Version: I used CI and created my website
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

El Forum

[eluser]chmod[/eluser]
My site is :

www.u966.com

El Forum

[eluser]daulex[/eluser]
awesome, I wish I could read it Smile

how did you get rid of the index.php in the url ? your links are site.com/pay/something, how did you drop the index.php ?

El Forum

[eluser]chmod[/eluser]
it's easy.
open config.php
and, $config['index_page'] = "index.php" => $config['index_page'] = "";
that's all.

El Forum

[eluser]Jamie Rumbelow[/eluser]
You also need a .htaccess for Apache to forward it properly.

But nice site!

El Forum

[eluser]daulex[/eluser]
[quote author="Jemgames" date="1213548657"]You also need a .htaccess for Apache to forward it properly.

But nice site![/quote]

can you give a working example?

El Forum

[eluser]Pascal Kriete[/eluser]
From the user guide.

Code:
RewriteEngine on

# Any folders/files that should not be rewritten
RewriteCond $1 !^(index\.php|images|robots\.txt)

# Removed the leading slash so it can be placed into subfolders
RewriteRule ^(.*)$ index.php/$1 [L]

El Forum

[eluser]daulex[/eluser]
[quote author="inparo" date="1213552017"]From the user guide.

Code:
RewriteEngine on

# Any folders/files that should not be rewritten
RewriteCond $1 !^(index\.php|images|robots\.txt)

# Removed the leading slash so it can be placed into subfolders
RewriteRule ^(.*)$ index.php/$1 [L]
[/quote]

I tried that, domain.com/index.php/aboutus works, domain.com/aboutus doesn't ( I'm using ASO, everything should be fine... ) what do I do?

El Forum

[eluser]chmod[/eluser]
try :

<Directory "D:/AppServ/www/">
Options Indexes FollowSymLinks MultiViews ExecCGI
RewriteEngine on
RewriteCond $1 !^(css|bbs|images|javascript|fckeditor|index\.php|robots\.txt)
RewriteRule ^(.*)$ /index.php/$1 [L]
AllowOverride All
Order allow,deny
Allow from all
</Directory>

El Forum

[eluser]daulex[/eluser]
[quote author="chmod" date="1213617456"]try :

<Directory "D:/AppServ/www/">
Options Indexes FollowSymLinks MultiViews ExecCGI
RewriteEngine on
RewriteCond $1 !^(css|bbs|images|javascript|fckeditor|index\.php|robots\.txt)
RewriteRule ^(.*)$ /index.php/$1 [L]
AllowOverride All
Order allow,deny
Allow from all
</Directory>[/quote]
500: Internal Server Error Sad

El Forum

[eluser]Colin Williams[/eluser]
http://codeigniter.com/wiki/mod_rewrite/
Pages: 1 2