CodeIgniter Forums

Full Version: Back to Square 1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]Unknown[/eluser]
Alright I have a website (duh) and keep getting an error

Quote:The XML data received was either invalid or not in the correct form for XML-RPC. Turn on debugging to examine the XML data further.

so I did some debugging, actually ALOT of debugging using log_message variable and found out its getting this error when it reaches Router.php under the section
Quote:function _validate_request($segments)
and gets to code
Code:
show_404($segments[0]);
And thats when it stops.. any help would be appreciated!

The other thing is i'm confused where I should set my "base_url". I have it currently set to
Code:
$config['base_url']    = "http://somewhere.net/";
although I have the codeigniter installed at
Code:
http://somewhere.net/xml-rpc-server/
^^^ that is where I have the index file for codeigniter. Any help would be appreciated. Thanks

Cold Assassin

El Forum

[eluser]charlie spider[/eluser]
set your base url to : http://somewhere.net/xml-rpc-server/

not a good enuf coder to help you with the first problem

El Forum

[eluser]metaltapimenye[/eluser]
change your config.php value
Code:
$config['base_url'] = 'http://somewhere.net/xml-rpc-server/'

'base_url' used to pointing 'domain/path/codeigniter/folder/index.php'

i hope it would help ^^

El Forum

[eluser]Unknown[/eluser]
Sorry for the long wait for reply, It was godaddy that was the issue, I have since found a free host (Host2x) to host the backbone of the application and has fixed the problem. Thanks all for your support.

Cold Assassin