CodeIgniter Forums

Full Version: Site developed in CI is not working properly [SOLVED]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]Mizanur Islam Laskar[/eluser]
Hello CI Experts,

I've just uploaded a music site developed in CodeIgniter under a LINUX server. The site is browseable here. The home page is showing up properly, but when I want to go for other sections ( like 'Music Store', 'Registration',..etc. ), I see errors like 'Page Not Found'. Note that, 'mode rewrite' is enabled and to escape index.php, I've written the following codes in .htaccess file:

Code:
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]


I'm too disappointed at the issue. Any help is appreciated. Thanks in advance.

Regards,
Mizan

El Forum

[eluser]jedd[/eluser]
Try renaming your .htaccess and trying this url:

http://www.mymusicrecord.com/index.php/music_store/

It looks to me like it's not actually an .htaccess file (though I'd go for the ./index... approach)

Was it the same .htaccess you were using on the dev site?

What changes did you make to your config files during deployment to production?

El Forum

[eluser]Mizanur Islam Laskar[/eluser]
Hello jedd, I've tried out that URL, but same result. The code I mentioned, is exactly I've written in my .htaccess file. So yes it is the same .htaccess file. I'm required not to show index.php. In config.php file, I've written the following for my base_url:
Code:
$config['base_url']= "http://www.mymusicrecord.com/";

El Forum

[eluser]jedd[/eluser]
I meant, rename the .htaccess file so it's no longer in play, and then try to navigate to your currently-not-working pages using the URL above. If they don't work, even then, it means that the problem is (probably) not related to your .htaccess file.

I'm assuming you have already verified nothing funny with your routes and so on?

Are you watching your apache log files to see what it's trying to hit, or bumping up your CI logging and checking for errors in there too? It's not a basic permissions problem on the files, etc?

The difficulty with this kind of problem is that it could be one of a hundred things -- and while it'd probably only take a few minutes to run through them once you were on the box, just trying to second guess each change that someone might have made that broke their system is a bit tiring.

El Forum

[eluser]Mizanur Islam Laskar[/eluser]
Well, I've just come round of the issue with the help of this link. But thanks a lot all of you, who also took my issue seriously.

El Forum

[eluser]masipung[/eluser]
For CI expert.

The contents of the. Htaccess which I keep in / home/user1

Code:
RewriteEngine on
     RewriteCond $ 1! ^ (Index \. Php | images | system | views | monitoring | playvideo | player | free | robots \. Txt | css | js | favicon \. Png)
     RewriteRule ^(.*)$ index.php / $ 1 [L]


But when I access the URLs still do not want to display the web page when I type in a URL without index.php. I've tried to equate the tutorial http://www.anmsaiful.net/blog/php/remove-codeigniter-index-php.html
For the server I use fedora core 6 and use the virtual host for the placement of their website (/ home).

Please help me ..: (