CodeIgniter Forums

Full Version: big problem with mod_rewrite
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]jparent[/eluser]
Hi I move my application from localhost to my hostsite (http://www.vigilant.es/vigilant/) and when my application was in localhost it removes de index.php correctly but now in http://www.vigilant.es/vigilant/ I need to add index.php to move to the other controllers like http://www.vigilant.es/vigilant/index.ph...controller.

this are my mods loaded, look mod_rewrite is enabled.

core mod_win32 mpm_winnt http_core mod_so mod_access mod_actions mod_alias mod_asis mod_auth mod_autoindex mod_cgi mod_dir mod_env mod_headers mod_imap mod_include mod_info mod_isapi mod_log_config mod_mime mod_negotiation mod_rewrite mod_setenvif mod_userdir sapi_apache2

My php version is: 4.4.3
My apache version is: Apache/2.0.59 under Win32 XP

My .htacces is

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond $1 !^(index\.php|img|img_public|css|js|\.txt|fckeditor|docs)
RewriteRule ^(.*)$ /vigilant/index.php/$1 [L]
</IfModule>
<IfModule !mod_rewrite.c>
ErrorDocument 404 index.php
</IfModule>

My conf.php file have:

$config['base_url'] = "http://www.vigilant.es/vigilant/";
$config['index_page'] = "";
$config['uri_protocol'] = "AUTO";

┬┐Could you help me?

El Forum

[eluser]InsiteFX[/eluser]
Check your apache config file, AllowOverride may be set to none.

Default for AllowOverride is none, should be all

Enjoy
InsiteFX

El Forum

[eluser]jparent[/eluser]
Thanks that was one of the problem. Now it shows internal server error (500) and at the log I find:

[Wed Oct 07 17:27:21 2009] [error] [client 212.170.48.229] File does not exist: C:/Archivos de programa/Apache Group/Apache2/htdocs/vigilant/noticias, referer: http://www.vigilant.es/vigilant/
[Wed Oct 07 17:27:36 2009] [alert] [client 212.170.48.229] C:/Archivos de programa/Apache Group/Apache2/htdocs/vigilant/.htaccess: Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration, referer: http://www.vigilant.es/vigilant/

El Forum

[eluser]jparent[/eluser]
Ok Ok, Its my fault!! I set de httpd.default.conf as default and rewrite module was off. I correct it and works! Thanks for your help!

El Forum

[eluser]BrianDHall[/eluser]
According to the RewriteEngine invalid error, it means mod_rewrite is not enabled in your Apache.