CodeIgniter Forums

Full Version: IE and session problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]Peter Lachky[/eluser]
Hi guys,

I went through many post regarding IE and sessions issue on this forum, however, I could not find an answer which would help me.

So - I have quite simple classified ads page so customer can edit his own ad if he logs in succesfully. That is where the sessions comes to effect. I would like to keep him logged for some time so he can spent some time editing the ad. This works in Safari, FF, but, as expected, does not in IE (checked IE6, IE7, IE8).

I have found several solutions:
1. Change the session cookie name so it does not contain underscores. Did not help.
2. Change the session expiration to some really high number (72000). Did not help either.
3. Check the server date settings against script settings. So I put the current timestamp display (php date function) in my page footer and it is exactly the same as the date on my computer. I have also checked the time zone. It is "Europe/Bratislava" both on the server (checked by phpinfo) and my script (set via date_default_timezone_set).

I have also checked the timestamp (last_activity) in ci_sessions table and it is actually 1 hour less than the time on my computer. It looks like it is GMT timezone which is one hour less than Europe/Bratislava. Nevertheless, this should not be a problem if the session expiration is set to 20 hours (72000).

At this point I am done.
Any ideas? (Ignore IE does not count) :-)
[email protected] works fine, [email protected] works fine as well.

Thanks a lot.

El Forum

[eluser]Peter Lachky[/eluser]
Ok, due to the lack of time and nervous customer :-) I solved this by using native PHP code. Anyway, if anybody would come up with a solution for this I'd be more than happy.

Keep CI'ing!

El Forum

[eluser]n0xie[/eluser]
I would take a look at the servertime. A lot of weird behaviour has been reported with IE and cookies. Follow the link in my signature. This is one of the 'features' of IE.