CodeIgniter Forums

Full Version: Mod_deflate not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]thors1982[/eluser]
This isn't really a codeigniter issue but I am using it and having problems with mod_deflate, I have gotten it to work on another server and without codeigniter but I can't get it working on my codeigniter site.

My phpinfo shows:
Code:
HTTP_ACCEPT_ENCODING     gzip,deflate

My htaccess file is:

Code:
<IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/xhtml text/html text/plain text/xml text/javascript application/x-javascript text/css
</IfModule>

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    #Removes access to the system folder by users.
    #Additionally this will allow you to create a System.php controller,
    #previously this would not have been possible.
    #'system' can be replaced if you have renamed your system folder.
    RewriteCond %{REQUEST_URI} ^system.*
    RewriteRule ^(.*)$ /index.php?/$1 [L]

    #Checks to see if the user is attempting to access a valid file,
    #such as an image or css document, if this isn't true it sends the
    #request to index.php
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    #This last condition enables access to the images and css folders, and the robots.txt file
    #Submitted by Michael Radlmaier (mradlmaier)
    RewriteCond $1 !^(index\.php|images|robots\.txt|css)
    RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>

<IfModule !mod_rewrite.c>
    # If we don't have mod_rewrite installed, all 404's
    # can be sent to index.php, and everything works as normal.
    # Submitted by: ElliotHaughin

    ErrorDocument 404 /index.php
</IfModule>

Does anyone know why this isn't working. I am not the best at htaccess.

Thanks a lot for your help and if you need anymore info just ask.