CodeIgniter Forums

Full Version: Very Very Werid Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]The Casual Bot[/eluser]
so im moved my site from a wamp setup to my newly build LAMP using ubuntu

apache2 and php5.3.3

but on my dashboard it displays 24 hour orders but i notice that there was a diffrence in the result on each server

on my wamp i had some
on my lamp i had none

but i did have any errors either and there both looking at the same DB
my code looks likes this
Code:
$DIMENSIONS = $this->load->database('DIMENSIONS', TRUE);
   $sql = 'select  oh_account, oh_order_number from ord_header where OH_URGENT_FLAG = 1 and oh_status <1';
   $query = $DIMENSIONS->query($sql);
//then some code below to just print this out

and it returns nothing
however if i do this
Code:
$DIMENSIONS = $this->load->database('DIMENSIONS', TRUE);
   $sql = 'select  oh_account, oh_order_number from ord_header where OH_URGENT_FLAG = 1 and oh_status <1';
   $query = $DIMENSIONS->query($sql);
   $test = $query->result_array();
   //the code below has'nt changed but now it works

so by puting the results in an array it starts to work again

note tho: $test does appear anywhere else in the doc just there and i can changes its name to anything and it still works

the db is mssql and im connecting via ODBC useing the freetds driver and unixodbc any clue to whats going on

El Forum

[eluser]The Casual Bot[/eluser]
i got a small udate on this

the objects num_rows is returning -1

El Forum

[eluser]InsiteFX[/eluser]
Read the other post I just answered ODBC and access always returns -1

Answered here!

InsiteFX