CodeIgniter Forums

Full Version: Blank page on server - again
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

El Forum

[eluser]Unknown[/eluser]

Hi there,
how apposite, my first post and I’m asking for a help :coolsmile:

This is the first time I use CI and application I wrote works perfectly on local windows machine with xampp (with PHP5). But after uploading to UNIX server (with PHP4.3) I get just blank page, without any error or smth. I haven’t use any “only PHP5” statement. I read in several topics here that possible reason could be syntax error in code, so I checked again code and everything seems to be ok, and also if I had syntax errors my application would throw some error on local machine. I checked config.php, routes.php and database.php and I think everything is ok.

config.php
$config['base_url'] = http://www.realaddress.com
$config['index_page'] = "";
$config['uri_protocol'] = "AUTO"; /* I also tried every other possibility except AUTO, but nothing happen */
$config['enable_query_strings'] = false;
$config['compress_output'] = FALSE;
$config['rewrite_short_tags'] = TRUE;

routes.php
$route['default_controller'] = "nekretnine";
$route['login'] = "nekretnine/login";
$route['nekretnine/index'] = "nekretnine";
$route['scaffolding_trigger'] = "";

database.php
$active_group = "default";
$db['default']['hostname'] = "real host"; /* double checked with administrators */
$db['default']['username'] = "real username"; /* double checked with administrators */
$db['default']['password'] = "real password"; /* double checked with administrators */
$db['default']['database'] = "real database"; /* double checked with administrators */
$db['default']['dbdriver'] = "mysql";
$db['default']['dbprefix'] = "";
$db['default']['active_r'] = TRUE;
$db['default']['pconnect'] = TRUE;
$db['default']['db_debug'] = TRUE;
$db['default']['cache_on'] = FALSE;
$db['default']['cachedir'] = "";

.htaccess
<IfModule mod_rewrite.c>
Options +FollowSymLinks
Options -Indexes
DirectoryIndex index.php
RewriteEngine on
RewriteBase /
RewriteCond $1 !^(index\.php|images|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]
</IfModule>

<IfModule !mod_rewrite.c>
# If we don't have mod_rewrite installed, all 404's
# can be sent to index.php, and everything works as normal.
# Submitted by: ElliotHaughin

ErrorDocument 404 /index.php
</IfModule>

First .htaccess was:

Options +FollowSymLinks
Options -Indexes
DirectoryIndex index.php
RewriteEngine on
RewriteBase /
RewriteCond $1 !^(index\.php|images|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]

but that also didn’t work. When I delete .htaccess on server I get same blank page.

In index.php file, application folder and system folder are correct.

Mod_rewrite is turned off on server and there is no way to get that turned on. I put as a first line in default controller -> index action echo “test”; die(); but I didn’t get that ‘test’ message, so my application don’t reach default controller.

I really don’t have any idea what else to try. Can someone please help me somehow? I’m completely beginner with web applications development and I even don’t know how to catch some log messages or similar. :red:

Thanks in advance, cheers guys.

El Forum

[eluser]exodus7[/eluser]
Ok, I'm very new to this, but I noticed that your config.php, does not have quotes around your domain name.

try it like this:

Code:
$config['base_url']= "http://www.yourdomain.com/";

El Forum

[eluser]Unknown[/eluser]
It has, my bad here.. Thx exodus7

El Forum

[eluser]jorre[/eluser]
I have the same problem here... works perfect locally, but online it gives a blank page, no errors whatseever

El Forum

[eluser]bcdennis[/eluser]
I had the same problem. For me, I had enabled logging and the log folder wasn't writeable by apache. chmod'ing the system/log folder did the trick.

El Forum

[eluser]jorre[/eluser]
Yep thanks, I found this out myself yesterday and that is indeed the problem. Also, my database driver was set to non-existing ISAMmysql

Thanks again

El Forum

[eluser]dark_lord[/eluser]
where did you saw the ISAMmysql?

I am having a problem in uploading my website... I have done all and looked for the best possible answer but seems I have found no good. I loosing hope in uploading my website and work it out properly... huhuhu... please help me...

El Forum

[eluser]Joey Marchy[/eluser]
Yes, make sure your system/logs/ directory is writable. That fixed it for me too.

El Forum

[eluser]shofe[/eluser]
Thanks... I just stumbled this one, and it's just about time when I am about to hit my head on the wall.. Smile