CodeIgniter Forums

Full Version: Should CI-4 require PHP 7.3 ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
(03-10-2019, 01:53 PM)Leo Wrote: [ -> ]I'm quite sure by that time ALL shared hostings will have 7.3 available (unless they're cheap and backwards then you shouldn't use 'em).

Not everyone is on shared hosting. We use CI at work for custom web apps on our intranet and you wouldn't believe how outdated our web servers are. It's very hard to convince the admins to upgrade the softwares because it's working as it is. So why take the risk...  Sad

Anyway. My opinion is that CI should require the lowest version possible, like it has always did in the past. If CI don't use any of the new feature, don't require the latest and greatest only for "marketing" purpose.
I agree with puschie on this one:

Quote:Or use 7.2 as min and 7.3 as recommended
I did a search on the hosts and found that most still use PHP 5.6.40 ....... That's why I can not use Laravel and I probably will not be able to use CodeIgniter 4 ......
(03-13-2019, 01:17 PM)includebeer Wrote: [ -> ]Anyway. My opinion is that CI should require the lowest version possible, like it has always did in the past. If CI don't use any of the new feature, don't require the latest and greatest only for "marketing" purpose.

I'll drink to that Smile

...and also add any supported PHP Version:

...otherwise itemised scripts where CI4 will possibly fail. This will give programmers to write workaround scripts if they require the relevant scripts ie email, databases.

https://en.wikipedia.org/wiki/PHP

PHP 5.6 supported until:  31 December 2018
(03-13-2019, 09:27 PM)nogueira Wrote: [ -> ]I did a search on the hosts and found that most still use PHP 5.6.40 ....... That's why I can not use Laravel and I probably will not be able to use CodeIgniter 4 ......

Curious as to the hosts you checked out. I check the "Top 10" (according to PC Magazine) and they all appear to offer at least PHP 7.2.
Google Cloud finally got PHP 7.2 for App Engine Standard late last year. Moving to 7.3 may make CI4 incompatible with a large swath of cloud services- I'm not sure what AWS and Azure are doing.

Edit: Looks like Azure supports 5.6, 7.0, 7.2. AWS is whatever version you to install.
IMO is better to require the oldest version possible. 
Some applications at my work are running on a ubuntu box with php 5.5.9 (not using CI though), and there is no reason to upgrade this server. 

I like the idea of deploying and never touch it again unless really required. 

If there is nothing really fancy in 7.3, then stick to 7.2
It would be best if it supports lowest possible (the features used for developing the framework itself) up to latest.
In case the framework works 100% under 7.2 why to skip it?

Seeing PHP 7.4 major feature (adding typed properties + preload) most likely CI 4.1 or 4.2 will require for sure min of PHP 7.4 so it will be good if we have at least 1 CI 4 vers with lower requirements.
(03-13-2019, 09:27 PM)nogueira Wrote: [ -> ]I did a search on the hosts and found that most still use PHP 5.6.40 ....... That's why I can not use Laravel and I probably will not be able to use CodeIgniter 4 ......

luckily, some give you option of choosing what version you intend using
I agree @sv3tli0, @puschie, the minimum should be 7.2 and recommended is 7.3.
Pages: 1 2