Welcome Guest, Not a member yet? Register   Sign In
Poll: Which PHP version features should CI 4 target?
You do not have permission to vote in this poll.
5.4
23.26%
20 23.26%
5.5
12.79%
11 12.79%
5.6
50.00%
43 50.00%
5.3 (unsuported already)
1.16%
1 1.16%
This should depend on dev process
12.79%
11 12.79%
Total 86 vote(s) 100%
* You voted for this item. [Show Results]

Which PHP 5.X version should be considered as Required
#41

I see a new note arrived since I started composing my previous one, pointing out that LTS versions of some platforms have their own limitations too.

Maybe a better question for the community would be "Are you willing to switch provider or platform, if needed for a CI4 using a higher version of PHP than you have"?
James Parry
Project Lead
Reply
#42

It may be worthwhile to have someone look up the support lifecycles for the operating systems used by various providers, if that information is available, as a means of predicting the versions which may be common at some point in the future. For instance, to use my previous example, it's likely that anyone using Ubuntu LTS releases on their servers will completely skip 5.4, but it's possible that their servers could continue running PHP 5.3 until 2017.

From a quick look around, though, such detailed information is rarely freely available, unless the hosting providers make it available on their own sites.
Reply
#43

(04-15-2015, 01:25 PM)jlp Wrote: I see a new note arrived since I started composing my previous one, pointing out that LTS versions of some platforms have their own limitations too.

Maybe a better question for the community would be "Are you willing to switch provider or platform, if needed for a CI4 using a higher version of PHP than you have"?

I guess we're jumping each other's posts here Smile

Personally, for the foreseeable future, I can push to use whatever PHP platform I wish, though getting outside of what is included in a well-supported OS release can be difficult, at best. I'm not particularly concerned about the choice of version making it difficult or impossible for me to use a future version of CI. The reasoning behind the choice is more important to me, as it tells me something about where the framework is headed.

A lot of developers are concerned that developing for a given version of PHP gives hosting providers and OS vendors a reason to stay with unsupported versions of PHP, and I can understand the reluctance in that case. However, I think most hosting providers and OS vendors are interested in system stability more than anything else, and, traditionally, the best way to maintain such stability is to severely limit the non-security related updates on that platform.

The majority of a given hosting provider's users will probably be using a pre-packaged framework or CMS, also provided by the host, or no framework at all. Additionally, very few frameworks have a maximum PHP version on which they will run at this time. So, unless the provider has a particularly close relationship with (or sees a particularly large demand for) a given framework, no single framework is likely to have much of an impact on what version of any software is available on a given provider's servers.

Of course, if any single software package could cause a wide-spread upgrade by hosting providers and server vendors, it would probably be WordPress. If they move their minimum version above CI's, it would probably be pretty safe to match it (but I don't see any evidence of that happening from their end).
Reply
#44

(04-15-2015, 01:25 PM)jlp Wrote: I see a new note arrived since I started composing my previous one, pointing out that LTS versions of some platforms have their own limitations too.

Maybe a better question for the community would be "Are you willing to switch provider or platform, if needed for a CI4 using a higher version of PHP than you have"?

For me, the question is: "Will my clients be willing to switch?". They have an invested base of code, running on their servers and will seldom consider an upgrade based solely on my recommended platform-of-choice.
CI 3.1 Kubuntu 19.04 Apache 5.x  Mysql 5.x PHP 5.x PHP 7.x
Remember: Obfuscation is a bad thing.
Clarity is desirable over Brevity every time.
Reply
#45

(04-15-2015, 01:25 PM)jlp Wrote: Maybe a better question for the community would be "Are you willing to switch provider or platform, if needed for a CI4 using a higher version of PHP than you have"?

The problem is this and its a big one for you guys.  CI is at the bottom tier when it comes to competence.  You have devs who are using shared hosting or working on the fringes of a already established application that's been running for 5+ years.  They aren't learning anything new so their knowledge is at 5.2-5.3.

That's why you are seeing such resistance about 5.4+ being installed.  They either have servers who can't support it or they have applications that won't take advantage of it.

If you want CI to start gaining market share and mindsets among developers you will need to split your focus.  Keep CI 3.X track for those who fit the came of staying at 5.3 until either their app needs upgrading or shared hosting providers upgrade.  Have a NEW 4.X track with all the bells and whistles and where PHP devs will take notice.

Otherwise, seriously.  CI is at the bottom run and it's not going to go anywhere.
Reply
#46

(04-15-2015, 09:03 PM)no1youknowz Wrote: They aren't learning anything new so their knowledge is at 5.2-5.3.

That's why you are seeing such resistance about 5.4+ being installed.

Maybe you can read the other posts before making that kind of comment. A lot of devs have little to no control on the PHP version installed on the server where their code will be installed. And I'm still waiting to see an answer to this question: "Is there a compelling technical reason to use 5.6 vs 5.5? A language feature that would make our lives a lot easier?"
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
Reply
#47

There's no compelling language features that I can see between 5.5 and 5.6, IIRC. Seems like it is mostly syntactic sugar.
Reply
#48

Let me point out a difference in my development platforms. As a developer, I write for my clients system, while recommending what I think works best for them. At the same time, my Personal system uses the newest available (in this instance; php 5.5.x - 5.6). So I want a framework which offers versions supporting all of these platforms. Yes, some of my code is still running on php 5.2.x and I still make income from supporting it. If I provide value, then my clients will offer me the job of upgrading when THEY upgrade their system. Business 101.

How many of you are not at least testing the latest and greatest?

I'll be testing php 7 when it reaches beta release, but I won't expect CI to match that release. Waiting for the debug process to fix the rough spots is, again, good business sense. My clients will be, at least, a full year behind the php release schedule. I'll be ready when they are.

Php 5.6 is ready for use now and I want a CI version which supports it.
CI 3.1 Kubuntu 19.04 Apache 5.x  Mysql 5.x PHP 5.x PHP 7.x
Remember: Obfuscation is a bad thing.
Clarity is desirable over Brevity every time.
Reply
#49

@twpmarketing This talk is about minimally supported version. Naturally if there is support for PHP 5.4, it doesn't mean it won't run on PHP 5.6. CI 3.0 is regularly tested and supported even on PHP 7 and HHVM.
Reply
#50

(This post was last modified: 04-18-2015, 01:57 PM by twpmarketing.)

(04-18-2015, 01:23 PM)gadelat Wrote: @twpmarketing This talk is about minimally supported version. Naturally if there is support for PHP 5.4, it doesn't mean it won't run on PHP 5.6. CI 3.0 is regularly tested and supported even on PHP 7 and HHVM.

Ummm:
Quote: Poll: Which PHP 5.X version should be considered as Required
jlp wrote:
Quote:Maybe a better question for the community would be "Are you willing to switch provider or platform, if needed for a CI4 using a higher version of PHP than you have"?

I really thought that was what I was addressing.  CI 4...  Sorry if you didn't get that from my post(s).

I want a version of CI 4 which, at a minimum, supports php 5.6, for the reasons I have stated above.  Forgive me but CI 3.0 cannot support php 7 because it does not yet exist...
CI 3.1 Kubuntu 19.04 Apache 5.x  Mysql 5.x PHP 5.x PHP 7.x
Remember: Obfuscation is a bad thing.
Clarity is desirable over Brevity every time.
Reply




Theme © iAndrew 2016 - Forum software by © MyBB