CodeIgniter Forums
Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 (/thread-11745.html)



Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Unknown[/eluser]
After change hosting, this error appear. WTF!?


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Derek Allard[/eluser]
code?


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Unknown[/eluser]
The probles are gone, without any changes, just few hours later everything is OK
This is Magic or Server ill... stay in touch, do not close please.


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Derek Allard[/eluser]
Won't close... we're all here to help each other. Welcome to CodeIgniter gox2, looking forward to reading more of your writing on these forums.


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Référencement Google[/eluser]
Seems there was a true bug here, I had an issue too with the latest SVN release (from today).
I was able to login to my website until I updated CI today. Reverting to an earlier revision of the Encrypt.php file solved the problem.


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Derek Allard[/eluser]
OK, Too Pixel, I think I found it. Could you try using the Encrypt.php in the SVN again and let me know what you get?


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-22-2008

[eluser]Référencement Google[/eluser]
Yup Derek, all is fine now, thanks ;-)


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-23-2008

[eluser]Derek Allard[/eluser]
Another change. It should still be good, but could you kinda update one more time and test for me?


Fatal error: Call to a member function on a non-object in /system/libraries/Encrypt.php on line 146 - El Forum - 09-23-2008

[eluser]Référencement Google[/eluser]
Tested: That's all fine Derek.