CodeIgniter Forums
Bad Gateway or 404page - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: Bad Gateway or 404page (/thread-15061.html)



Bad Gateway or 404page - El Forum - 01-25-2009

[eluser]tabatsoy[/eluser]
Hi there,

Can somebody please help me. When I go to my website (eg. http://mysite.com/CI/) it is ok but when I click on my link on the index it gives me a 502 Bad Gateway.

I put a .htaccess file just like on the wiki and when I remove the index.php on the config I’m getting a 404 error Not Found.

I’m using plesk and the version of php is 5.

I changed the uri_protocol to request_uri.

Please help

Thanks and I will appreciate any response


Bad Gateway or 404page - El Forum - 01-25-2009

[eluser]Phil Sturgeon[/eluser]
This is something you will have to talk to your hosting/server admin about as a 502 error will not be anything to do with CodeIgniter.


Bad Gateway or 404page - El Forum - 09-11-2010

[eluser]hugle[/eluser]
[quote author="Phil Sturgeon" date="1232936183"]This is something you will have to talk to your hosting/server admin about as a 502 error will not be anything to do with CodeIgniter.[/quote]

Today I had a problem, with 502 error: '502 Bad Gateway' when I was using PyroCMS ( v.9.9.7, latest stable). (it was some russian hosting server (never had such problems before on my servers))

I started going step by step. Later I understood, that smth is wrong with Encrypt library (maybe some things not supported or smth ilke that) and I came to solution like this:

Downloaded the Encrypt.php from CI 2.0 branch

and also had turned on database sessions like this:
$config['sess_use_database'] = TRUE;

I I switch back to 1.7.2 Encrypt library or disable the sessions in database I get the error again.

Wanted to post here so anyone else having similar problems on BUGGY servers would save some of their time Smile


Bad Gateway or 404page - El Forum - 10-02-2010

[eluser]Unknown[/eluser]
Today I had this same error with CI 1.7.2. I solved it inspired in hugle's solution by changing this config setting in config.php:

$config['sess_encrypt_cookie'] = FALSE;

This seems to not encrypt the cookies and it worked OK. (Buggy Encrypt library maybe?)...