CodeIgniter Forums
Your view folder path does not appear to be set correctly. Please open the following - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Using CodeIgniter (https://forum.codeigniter.com/forum-5.html)
+--- Forum: General Help (https://forum.codeigniter.com/forum-24.html)
+--- Thread: Your view folder path does not appear to be set correctly. Please open the following (/thread-1641.html)



Your view folder path does not appear to be set correctly. Please open the following - avinashizhere - 03-28-2015

how is it even possible, i downloaded a fresh copy of codeigniter, my last ci3 project working fine :/ error Your view folder path does not appear to be set correctly. Please open the following file and correct this: index.php


RE: Your view folder path does not appear to be set correctly. Please open the following - Rufnex - 03-28-2015

Did you mix CI2 with C3 together?


RE: Your view folder path does not appear to be set correctly. Please open the following - kevgathuku - 03-31-2015

I'm also getting the exact same error on a fresh install of Codeigniter 3.
What could be the problem here?

For my installation, I am setting up CI on a subdirectory and the only change I have made is to set the $config['base_url']


RE: Your view folder path does not appear to be set correctly. Please open the following - gadelat - 03-31-2015

check permissions of views folder and compare it to index.php


RE: Your view folder path does not appear to be set correctly - kabeza - 04-08-2015

I had this problem tomorrow, with a fresh new CI install, latest 3.0 release.
It happens only in unix/linux environments. I solved it by:

1. set the project folder permission to 755. Eg. sudo chmod 755 /var/www/myCIproject/
2. sudo find /var/www/myCIproject/ -type d -exec chmod 755 {} \;

The last line searchs for every folder inside myCIproject (including application/views/) folder and chmods 755
I know it is a dirty solution, but it worked fine for me


RE: Your view folder path does not appear to be set correctly - coscho - 01-24-2016

(04-08-2015, 04:59 PM)kabeza Wrote: I had this problem tomorrow, with a fresh new CI install, latest 3.0 release.
It happens only in unix/linux environments. I solved it by:

1. set the project folder permission to 755. Eg. sudo chmod 755 /var/www/myCIproject/
2. sudo find /var/www/myCIproject/ -type d -exec chmod 755 {} \;

The last line searchs for every folder inside myCIproject (including application/views/) folder and chmods 755
I know it is a dirty solution, but it worked fine for me

This works for me also !!!