CodeIgniter Forums
PHP 5.3.0 Compatibility - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: PHP 5.3.0 Compatibility (/thread-21042.html)

Pages: 1 2 3 4 5 6


PHP 5.3.0 Compatibility - El Forum - 07-29-2009

[eluser]Derek Jones[/eluser]
Hey everybody, just stopping by to drop a note for those who are interested and are running PHP 5.3 on their dev boxes, that the subversion repo for the in-development v1.7.2 has been updated for compatibility with PHP 5.3.0.

If you encounter any issues, feel free to post them to this thread, or to the bug forum / tracker dropping a note here.


PHP 5.3.0 Compatibility - El Forum - 07-30-2009

[eluser]Yash[/eluser]
Thank you so much


PHP 5.3.0 Compatibility - El Forum - 07-30-2009

[eluser]InsiteFX[/eluser]
Thank you very much.

Enjoy
InsiteFX


PHP 5.3.0 Compatibility - El Forum - 07-30-2009

[eluser]Kami_[/eluser]
Great, I'm glad to hear it!

Maybe it wouldn't be a bad idea to put news on the website so people won't get the impression that CodeIgniter was left behind and the team doesn't care about the big leap in the PHP world (PHP 5.3).


PHP 5.3.0 Compatibility - El Forum - 07-30-2009

[eluser]Derek Jones[/eluser]
It didn't seem fitting for a news posting until the product is actually released with these changes; this forum post is a precursor.


PHP 5.3.0 Compatibility - El Forum - 07-30-2009

[eluser]Yash[/eluser]
any rough idea for next release?


PHP 5.3.0 Compatibility - El Forum - 07-31-2009

[eluser]Derek Allard[/eluser]
No ideas yet, but you have the most up to date code through the svn.


PHP 5.3.0 Compatibility - El Forum - 07-31-2009

[eluser]Yash[/eluser]
SVN may contains unstable code? or it is safe for live sites.


PHP 5.3.0 Compatibility - El Forum - 07-31-2009

[eluser]Derek Allard[/eluser]
Hey, which is it? Do you want cutting edge or stable? Pick one! :-P

Quote:Every effort is made to keep this codebase functional, but we cannot guarantee the functionality of code taken from the repository.

That said, you getting in there and testing it will only help how quickly it emerges as stable.


PHP 5.3.0 Compatibility - El Forum - 07-31-2009

[eluser]Yash[/eluser]
ok I got