CodeIgniter Forums
I can not get <?= to work on one of my servers, any ideas why ? - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forumdisplay.php?fid=20)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forumdisplay.php?fid=21)
+--- Thread: I can not get <?= to work on one of my servers, any ideas why ? (/showthread.php?tid=22868)

Pages: 1 2


I can not get <?= to work on one of my servers, any ideas why ? - El Forum - 10-01-2009

[eluser]BrianDHall[/eluser]
I've run into a lot of pain with PHP 5.3 myself, with out without CI at all. My XDebug on Vista 64-bit wouldn't work no matter what I did, CI throws lots of deprecated errors about stuff I don't even understand why it would be deprecated, etc etc.

I fixed all these issues very simple - I went back to the latest version of PHP 5.2. I think a new version of CI might be needed to fully address all PHP 5.3 issues - you might consider a bug report on that one though after looking into it a bit.


I can not get <?= to work on one of my servers, any ideas why ? - El Forum - 10-01-2009

[eluser]nizsmo[/eluser]
[quote author="BrianDHall" date="1254441301"]I've run into a lot of pain with PHP 5.3 myself, with out without CI at all. My XDebug on Vista 64-bit wouldn't work no matter what I did, CI throws lots of deprecated errors about stuff I don't even understand why it would be deprecated, etc etc.

I fixed all these issues very simple - I went back to the latest version of PHP 5.2. I think a new version of CI might be needed to fully address all PHP 5.3 issues - you might consider a bug report on that one though after looking into it a bit.[/quote]

v1.7.2 of CI should fix all the compatibility issues of PHP 5.3, does it not for you?


I can not get <?= to work on one of my servers, any ideas why ? - El Forum - 10-01-2009

[eluser]BrianDHall[/eluser]
[quote author="nizsmo" date="1254443615"][quote author="BrianDHall" date="1254441301"]I've run into a lot of pain with PHP 5.3 myself, with out without CI at all. My XDebug on Vista 64-bit wouldn't work no matter what I did, CI throws lots of deprecated errors about stuff I don't even understand why it would be deprecated, etc etc.

I fixed all these issues very simple - I went back to the latest version of PHP 5.2. I think a new version of CI might be needed to fully address all PHP 5.3 issues - you might consider a bug report on that one though after looking into it a bit.[/quote]

v1.7.2 of CI should fix all the compatibility issues of PHP 5.3, does it not for you?[/quote]

I upgraded to 5.3 by trying out XAMPP and copied over my current project and it threw a ton of depracated errors. I 'fixed' this by setting the ~DEPRECATED flag in my index file, but I didn't really feel good about all the errors.

I was just trying to get debugging to work so I took the easy way out and said "%*@! it".