CodeIgniter Forums
htaccess/routing/server issues - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: htaccess/routing/server issues (/thread-25249.html)



htaccess/routing/server issues - El Forum - 12-05-2009

[eluser]ocergyNohtna[/eluser]
for the life of me i don't know how many times i've run into the most retarded issues when going from one server to another...ugh... here's my issue....

http://www.example.com/folderA/func1/ does NOT route and i get the following back:
Code:
Not Found
The requested URL /example.com/folderA/index.php/func1 was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.33 Server at www.example.com Port 80

but if i go directly to http://www.example.com/folderA/index.php/func1/ i get what i expect.

there are multiple ci installs (i.e. folderA is one of them) and i have an htaccess file within each of my main folders (again, i.e. folderA) with the following:
Code:
RewriteEngine On
RewriteCond $1 !^(index\.php|robots\.txt|images|css|js)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/$ index.php/$1 [L]

even more strange is the fact that in another folder with another ci install only http://www.example.com/folderB/index.php/ works http://www.example.com/folderB/index.php/func1/ returns a CI 404 error page as opposed to the default 404 i got in the other case. both htaccess files are identical. CI's config.php has index.php removed and i've had to change my URI protocol to request_uri due to this server the client has - never even had to bother with it before, but don't think that's part of the issue. correct me...lol WTF is going on here? any thoughts? suggestions to seeing the madness? everything else is pretty much default.


htaccess/routing/server issues - El Forum - 12-05-2009

[eluser]JoostV[/eluser]
Have you tried
Code:
RewriteRule ^(.*)/$ /folderA/index.php/$1 [L]



htaccess/routing/server issues - El Forum - 12-08-2009

[eluser]ocergyNohtna[/eluser]
that just results in a 404 like:

The requested URL /example.com/folderA/folderA/index.php/document was not found on this server.