CodeIgniter Forums
URI Charatcters problem - Printable Version

+- CodeIgniter Forums (
+-- Forum: Archived Discussions (
+--- Forum: Archived Development & Programming (
+--- Thread: URI Charatcters problem (/thread-25922.html)

URI Charatcters problem - El Forum - 12-30-2009

Hi guys, just a simple question for you.

How can I make this URL readable from CI?{:N{T&url;=}[email protected]^W4qW!:Dc::/CK_@

An Error Was Encountered

The URI you submitted has disallowed characters.

In my config.php:
$config['enable_query_strings'] = FALSE;
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-';
$config['uri_protocol'] = "QUERY_STRING";

Thank you

URI Charatcters problem - El Forum - 12-31-2009

[eluser]Chad Fulton[/eluser]
Whoa! So many issues here.

1. What's the deal with putting twice? Was that intended?

2. Must you use query strings? That's not the "CodeIgniter" way. If you must, there are a whole bunch of threads to help you there. (If this is what you're trying to do, what's with the &url; part? That's not an HTML entity that I know of. Are you trying to get a second GET variable in there?)

3. It looks like you're using some kind of encoding in the query string. Why are you encoding it? What's the reason for encoding it with whatever you're using (which is not url safe) instead of encoding it with urlencode() and urldecode() functions?

4. If you do really want to use query strings and not change the encoding, you'll have to enable query strings, and then add the characters you want to allow (looks like you'll need ={}&^[email protected]/ at least, and maybe more depending upon what sort of encoding you're using).